summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-09-09 15:42:13 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-09-09 15:42:13 +0000
commitbd6811f001f762e2a6040a38a3f3861f10ce0244 (patch)
treea4bb55152afa2da41b1991a0c81a6f97c0fd665f /kde-base
parentRemove stale versions, mark 3.3.0 x86 stable (diff)
downloadhistorical-bd6811f001f762e2a6040a38a3f3861f10ce0244.tar.gz
historical-bd6811f001f762e2a6040a38a3f3861f10ce0244.tar.bz2
historical-bd6811f001f762e2a6040a38a3f3861f10ce0244.zip
remove old version
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/arts/arts-1.2.1.ebuild83
-rw-r--r--kde-base/arts/files/arts-1.2.1-buffer.patch27
-rw-r--r--kde-base/arts/files/digest-arts-1.2.11
3 files changed, 0 insertions, 111 deletions
diff --git a/kde-base/arts/arts-1.2.1.ebuild b/kde-base/arts/arts-1.2.1.ebuild
deleted file mode 100644
index 376b8609db03..000000000000
--- a/kde-base/arts/arts-1.2.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.1.ebuild,v 1.15 2004/08/30 15:45:00 pvdabeel Exp $
-
-inherit kde flag-o-matic eutils
-set-kdedir 3.2
-
-DESCRIPTION="aRts, the KDE sound (and all-around multimedia) server/output manager"
-HOMEPAGE="http://multimedia.kde.org/"
-SRC_URI="mirror://kde/stable/${PV/1.2.1/3.2.1}/src/${PN}-${PV}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="3.2"
-KEYWORDS="x86 ppc sparc hppa amd64 ~alpha ~ia64"
-IUSE="alsa oggvorbis esd artswrappersuid mad"
-
-DEPEND="alsa? ( media-libs/alsa-lib virtual/alsa )
- oggvorbis? ( media-libs/libvorbis media-libs/libogg )
- esd? ( media-sound/esound )
- mad? ( media-libs/libmad media-libs/libid3tag )
- media-libs/audiofile
- >=dev-libs/glib-2
- >=x11-libs/qt-3.2
- >=sys-apps/portage-2.0.49-r8"
-
-# patch to configure.in.in that makes the vorbis, libmad deps optional
-# has no version number in its filename because it's the same for all
-# arts versions - the patched file hasn't changed in a year's time
-# PATCHES="$FILESDIR/optional-deps.diff"
-
-src_unpack() {
- kde_src_unpack
- kde_sandbox_patch ${S}/soundserver
- # for the configure.in.in patch, for some reason it's not automatically picked up
- # rm -f $S/configure
-
- cd ${S}
- use amd64 && epatch ${FILESDIR}/arts-${PV}-buffer.patch
- # this patch fixes the high cpu usage of mp3 and vorbis
- epatch ${FILESDIR}/arts-vorbis-fix.dif
-}
-
-src_compile() {
- #fix bug 13453
- filter-flags -foptimize-sibling-calls
-
- #fix bug 41980
- use sparc && filter-flags -fomit-frame-pointer
-
- myconf="$myconf `use_enable alsa`"
- myconf="$myconf `use_enable oggvorbis vorbis`"
- myconf="$myconf `use_enable mad libmad`"
-
- kde_src_compile
-}
-
-src_install() {
- kde_src_install
- dodoc ${S}/doc/{NEWS,README,TODO}
-
- # moved here from kdelibs so that when arts is installed
- # without kdelibs it's still in the path.
- dodir /etc/env.d
-echo "PATH=${PREFIX}/bin
-ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
-LDPATH=${PREFIX}/lib
-CONFIG_PROTECT=${PREFIX}/share/config" > ${D}/etc/env.d/48kdepaths-3.2.1 # number goes down with version upgrade
-
- echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/57kdedir-3.2.1 # number goes up with version upgrade
-
- # used for realtime priority, but off by default as it is a security hazard
- use artswrappersuid && chmod +s ${D}/${PREFIX}/bin/artswrapper
-}
-
-pkg_postinst() {
- if ! use artswrappersuid ; then
- einfo "Run chmod +s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
- einfo "and so avoid possible skips in sound. However, on untrusted systems this"
- einfo "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
- einfo "priority, and so is off by default. See bug #7883."
- einfo "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
- fi
-}
diff --git a/kde-base/arts/files/arts-1.2.1-buffer.patch b/kde-base/arts/files/arts-1.2.1-buffer.patch
deleted file mode 100644
index b8bb4a94ec9f..000000000000
--- a/kde-base/arts/files/arts-1.2.1-buffer.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- mcop/buffer.cc.orig 2004-03-24 14:51:23.586055192 +0100
-+++ mcop/buffer.cc 2004-03-24 14:56:14.054897216 +0100
-@@ -87,9 +87,8 @@
- void Buffer::writeFloat(float f) {
- // FIXME: on some machines this may fail badly (there is explicit
- // float marshalling and demarshalling code in mico/orb/util.cc)
--
-- long *f_as_long = (long *)&f;
-- writeLong(*f_as_long);
-+ union { float f; long l; } u = {f};
-+ writeLong(u.l);
- }
-
- void Buffer::writeFloatSeq(const std::vector<float>& seq) {
-@@ -252,9 +251,10 @@
- float Buffer::readFloat()
- {
- // FIXME: see writeFloat()
-- long f_as_long = readLong();
-+ union {float f; long l; } u;
-+ u.l = readLong();
-
-- if(!_readError) return *(float *)&f_as_long;
-+ if(!_readError) return u.f;
- return 0.0;
- }
-
diff --git a/kde-base/arts/files/digest-arts-1.2.1 b/kde-base/arts/files/digest-arts-1.2.1
deleted file mode 100644
index c0963f093e32..000000000000
--- a/kde-base/arts/files/digest-arts-1.2.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 84877632917893438c629803e7b004f3 arts-1.2.1.tar.bz2 1039479