summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-20 04:32:06 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-20 04:32:06 +0000
commite5c4097b667c153fd98c517775ad464380c299b5 (patch)
treea2c5427e5b066794620d471868d5964b81e74b9f /media-fonts/shinonome/shinonome-0.9.11.ebuild
parentVersion bumped. (diff)
downloadhistorical-e5c4097b667c153fd98c517775ad464380c299b5.tar.gz
historical-e5c4097b667c153fd98c517775ad464380c299b5.tar.bz2
historical-e5c4097b667c153fd98c517775ad464380c299b5.zip
Version bumped. Uses font.eclass.
Diffstat (limited to 'media-fonts/shinonome/shinonome-0.9.11.ebuild')
-rw-r--r--media-fonts/shinonome/shinonome-0.9.11.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-fonts/shinonome/shinonome-0.9.11.ebuild b/media-fonts/shinonome/shinonome-0.9.11.ebuild
new file mode 100644
index 000000000000..9907fc55a7ec
--- /dev/null
+++ b/media-fonts/shinonome/shinonome-0.9.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/shinonome/shinonome-0.9.11.ebuild,v 1.1 2004/10/20 04:32:06 usata Exp $
+
+inherit font
+
+IUSE=""
+
+DESCRIPTION="Japanese bitmap fonts for X"
+SRC_URI="http://openlab.jp/efont/dist/shinonome/${P}.tar.bz2"
+HOMEPAGE="http://openlab.jp/efont/shinonome/"
+
+LICENSE="public-domain"
+SLOT=0
+KEYWORDS="~x86 ~alpha ~sparc ~ppc ~amd64"
+
+DEPEND="virtual/libc
+ virtual/x11
+ dev-lang/perl
+ sys-apps/gawk"
+RDEPEND=""
+
+FONT_SUFFIX="pcf.gz"
+FONT_S=${S}
+DOCS="AUTHORS BUGS ChangeLog* DESIGN* INSTALL LICENSE README THANKS TODO"
+
+src_compile(){
+ econf --with-pcf --without-bdf || die
+ emake || die
+
+ for i in *.pcf ; do
+ gzip -9 $i
+ done
+}