summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-08-27 17:00:05 +0000
committerAron Griffis <agriffis@gentoo.org>2005-08-27 17:00:05 +0000
commit94481392fcc8a8e0b023e5ab3dcc70f3b05df136 (patch)
treeb4042b323d24db39652d63da9d0fe6f547ca7a50 /media-gfx/gtkam/gtkam-0.1.12-r1.ebuild
parentbug #103487 (diff)
downloadhistorical-94481392fcc8a8e0b023e5ab3dcc70f3b05df136.tar.gz
historical-94481392fcc8a8e0b023e5ab3dcc70f3b05df136.tar.bz2
historical-94481392fcc8a8e0b023e5ab3dcc70f3b05df136.zip
Mark 0.1.12 stable on amd64 x86. Add 0.1.12-r1 which re-enables gnome
support and fixes a doc error, thanks to Tobias Sager #61248 Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-gfx/gtkam/gtkam-0.1.12-r1.ebuild')
-rw-r--r--media-gfx/gtkam/gtkam-0.1.12-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild b/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild
new file mode 100644
index 000000000000..aa16057a3ac7
--- /dev/null
+++ b/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild,v 1.1 2005/08/27 17:00:04 agriffis Exp $
+
+inherit eutils gnome2
+
+IUSE="exif gnome nls"
+
+DESCRIPTION="A frontend for gPhoto 2"
+HOMEPAGE="http://gphoto.org/proj/gtkam"
+SRC_URI="mirror://sourceforge/gphoto/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=media-libs/libgphoto2-2.1.6
+ exif? ( media-libs/libexif-gtk media-libs/libexif )
+ gnome? ( >=gnome-base/libbonobo-2 >=gnome-base/libgnomeui-2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-0.1.10-norpm.patch
+ epatch ${FILESDIR}/${PN}-0.1.12-helpdoc.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_with exif) \
+ $(use_with gnome gnome) \
+ $(use_with gnome bonobo) \
+ --with-rpmbuild=/bin/false --without-gimp
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ rm -rf ${D}/usr/share/doc/gtkam
+ dodoc ABOUT-NLS AUTHORS COPYING INSTALL MANUAL NEWS README
+}