summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2010-07-21 22:43:04 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2010-07-21 22:43:04 +0000
commit4bc496a0a85118d3bb91ca3f7436e8657fbef57c (patch)
tree91a45bfdf8d652e8e96cb6c2c91926473849bb93 /media-gfx/iscan/files
parentstable x86, security bug 329279 (diff)
downloadhistorical-4bc496a0a85118d3bb91ca3f7436e8657fbef57c.tar.gz
historical-4bc496a0a85118d3bb91ca3f7436e8657fbef57c.tar.bz2
historical-4bc496a0a85118d3bb91ca3f7436e8657fbef57c.zip
version bump. solving bug #302624.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/iscan/files')
-rw-r--r--media-gfx/iscan/files/iscan-2.25.0-drop-ltdl.patch64
-rw-r--r--media-gfx/iscan/files/iscan-2.25.0-fix-g++-test.patch13
2 files changed, 77 insertions, 0 deletions
diff --git a/media-gfx/iscan/files/iscan-2.25.0-drop-ltdl.patch b/media-gfx/iscan/files/iscan-2.25.0-drop-ltdl.patch
new file mode 100644
index 000000000000..8ac18defc007
--- /dev/null
+++ b/media-gfx/iscan/files/iscan-2.25.0-drop-ltdl.patch
@@ -0,0 +1,64 @@
+diff -Naur iscan-2.25.0.orig//backend/Makefile.am iscan-2.25.0/backend/Makefile.am
+--- iscan-2.25.0.orig//backend/Makefile.am 2010-05-19 07:51:55.000000000 +0200
++++ iscan-2.25.0/backend/Makefile.am 2010-07-21 22:49:08.579705272 +0200
+@@ -56,7 +56,6 @@
+
+ libepkowa_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+- $(LTDLINCL) \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/non-free \
+ $(XML_CFLAGS) \
+@@ -66,7 +65,7 @@
+ libepkowa_la_LIBADD = \
+ -lm \
+ $(XML_LIBS) \
+- $(LIBLTDL)
++ -lltdl
+ libepkowa_la_SOURCES = \
+ $(sane_backends_files) \
+ marshal.c \
+diff -Naur iscan-2.25.0.orig//configure.ac iscan-2.25.0/configure.ac
+--- iscan-2.25.0.orig//configure.ac 2010-07-21 22:48:11.411332268 +0200
++++ iscan-2.25.0/configure.ac 2010-07-21 22:49:58.918332411 +0200
+@@ -261,13 +261,10 @@
+ dnl The somewhat obscure LT_AC_PROG_SED is here to make sure that the
+ dnl SED environment variable gets set before it's used by the libtool
+ dnl machinery. This works around buggy libtool versions.
+-LT_AC_PROG_SED
+-AC_LIBLTDL_INSTALLABLE
+-AC_LIBTOOL_DLOPEN
+ AC_PROG_LIBTOOL
+-AC_LIB_LTDL
+-AC_SUBST(LTDLINCL)
+-AC_SUBST(LIBLTDL)
++AC_LTDL_SHLIBPATH
++AC_LTDL_SHLIBEXT
++AC_LTDL_SYSSEARCHPATH
+
+
+ dnl Graphic file format options
+diff -Naur iscan-2.25.0.orig//frontend/Makefile.am iscan-2.25.0/frontend/Makefile.am
+--- iscan-2.25.0.orig//frontend/Makefile.am 2010-05-19 07:51:54.000000000 +0200
++++ iscan-2.25.0/frontend/Makefile.am 2010-07-21 22:50:53.965581385 +0200
+@@ -34,7 +34,7 @@
+ iscan_LDADD = \
+ $(top_builddir)/lib/libimage-stream.la \
+ -lsane \
+- @LIBLTDL@ \
++ -lltdl \
+ @GTK_LIBS@ \
+ @GDK_IMLIB_LIBS@ \
+ $(top_builddir)/non-free/libesmod.so
+diff -Naur iscan-2.25.0.orig//lib/Makefile.am iscan-2.25.0/lib/Makefile.am
+--- iscan-2.25.0.orig//lib/Makefile.am 2010-05-19 07:51:56.000000000 +0200
++++ iscan-2.25.0/lib/Makefile.am 2010-07-21 22:51:29.794329919 +0200
+@@ -29,7 +29,7 @@
+ libimage_stream_la_CPPFLAGS = -I$(top_srcdir)/include
+ libimage_stream_la_LDFLAGS = -static
+ libimage_stream_la_LIBADD = \
+- $(LIBLTDL) \
++ -lltdl \
+ $(top_builddir)/lib/pdf/libpdf.la
+ libimage_stream_la_SOURCES = \
+ $(libimage_stream_la_files)
diff --git a/media-gfx/iscan/files/iscan-2.25.0-fix-g++-test.patch b/media-gfx/iscan/files/iscan-2.25.0-fix-g++-test.patch
new file mode 100644
index 000000000000..23fa6edd76b4
--- /dev/null
+++ b/media-gfx/iscan/files/iscan-2.25.0-fix-g++-test.patch
@@ -0,0 +1,13 @@
+Index: iscan-2.21.0/configure.ac
+===================================================================
+--- iscan-2.21.0.orig/configure.ac
++++ iscan-2.21.0/configure.ac
+@@ -68,7 +68,7 @@ AC_PROG_CXX
+ # to be larger than that for the gcc-3.[23] packages (as long as both
+ # are distributed) for smooth upgrade paths.
+
+-if test x"$CXX" = xg++; then
++if test "$GXX" = "yes"; then
+ AC_MSG_CHECKING([C++ ABI version])
+ CXX_ABI="`$CXX -E -dM - < /dev/null | $AWK '/GXX_ABI/ { print $3 }'`"
+ AC_MSG_RESULT([$CXX_ABI])