summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-09-04 10:45:05 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-09-04 10:45:05 +0000
commitc7d3f350e7c621183cbc30de7114c7afd65ea31b (patch)
tree7749bfd37866410f3d18fcda1d9ec99f70b15fdb /media-gfx/mandelbulber/files
parentpymsn-t: fix deprecations in python and init-script, port to eapi 3 (diff)
downloadhistorical-c7d3f350e7c621183cbc30de7114c7afd65ea31b.tar.gz
historical-c7d3f350e7c621183cbc30de7114c7afd65ea31b.tar.bz2
historical-c7d3f350e7c621183cbc30de7114c7afd65ea31b.zip
Version bump wrt #380327 by Tim Harder <radhermit@gentoo.org>, drop old
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/mandelbulber/files')
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.00-gcc46.patch12
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.05-overflow.patch11
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.08-qa.patch (renamed from media-gfx/mandelbulber/files/mandelbulber-1.00-qa.patch)16
3 files changed, 6 insertions, 33 deletions
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.00-gcc46.patch b/media-gfx/mandelbulber/files/mandelbulber-1.00-gcc46.patch
deleted file mode 100644
index 2a4e6657864e..000000000000
--- a/media-gfx/mandelbulber/files/mandelbulber-1.00-gcc46.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Fix building with GCC 4.6
-
---- src/fractal.h
-+++ src/fractal.h
-@@ -9,6 +9,7 @@
- #define FRACTAL_H_
-
- #include <vector>
-+#include <cstddef>
- #include "common_math.h"
- #include "fractparams.h"
-
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.05-overflow.patch b/media-gfx/mandelbulber/files/mandelbulber-1.05-overflow.patch
deleted file mode 100644
index af4170fa65a2..000000000000
--- a/media-gfx/mandelbulber/files/mandelbulber-1.05-overflow.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/callbacks.cpp
-+++ src/callbacks.cpp
-@@ -1663,7 +1663,7 @@
- {
- const char *filename = gtk_file_chooser_get_preview_filename(file_chooser);
-
-- char string[12];
-+ char string[13];
-
- FILE *fileSettings = fopen(filename, "r");
- if (fileSettings)
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.00-qa.patch b/media-gfx/mandelbulber/files/mandelbulber-1.08-qa.patch
index 447bea5fdad8..e94c97fbbd32 100644
--- a/media-gfx/mandelbulber/files/mandelbulber-1.00-qa.patch
+++ b/media-gfx/mandelbulber/files/mandelbulber-1.08-qa.patch
@@ -1,20 +1,16 @@
-Respect CXX,CXXFLAGS, fix as-needed
-
-Patch written by Kacper Kowalik <xarthisius@gentoo.org>
-
---- a/makefiles/makefile
-+++ b/makefiles/makefile
+--- makefiles/makefile.orig 2011-09-04 12:36:07.388901054 +0200
++++ makefiles/makefile 2011-09-04 12:37:15.301900642 +0200
@@ -44,7 +44,7 @@
mandelbulber: $(OBJS) $(USER_OBJS)
@echo 'Building target: $@'
@echo 'Invoking: GCC C++ Linker'
-- g++ `pkg-config --libs gtk+-2.0 gthread-2.0` -o"mandelbulber" $(OBJS) $(USER_OBJS) $(LIBS)
-+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o "mandelbulber" $(OBJS) $(USER_OBJS) `pkg-config --libs gtk+-2.0 gthread-2.0` $(LIBS)
+- g++ `pkg-config --libs gtk+-2.0 gthread-2.0` -o"mandelbulber"$(OBJS) $(USER_OBJS) $(LIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(USER_OBJS) `pkg-config --libs gtk+-2.0 gthread-2.0` $(LIBS)
@echo 'Finished building target: $@'
@echo ' '
---- a/makefiles/src/subdir.mk
-+++ b/makefiles/src/subdir.mk
+--- makefiles/src/subdir.mk.orig 2011-09-04 12:37:21.200901233 +0200
++++ makefiles/src/subdir.mk 2011-09-04 12:37:57.896900659 +0200
@@ -65,7 +65,7 @@
src/%.o: ../src/%.cpp
@echo 'Building file: $<'