summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2009-12-21 21:04:42 +0000
committerDror Levin <spatz@gentoo.org>2009-12-21 21:04:42 +0000
commit46663f19413fd48553eb4c229035478fa6fbb5bf (patch)
tree6a03b0d12beac52c7bd5303b46919c8808987987 /media-gfx/pngcrush/pngcrush-1.7.6.ebuild
parentVersion bump. (diff)
downloadhistorical-46663f19413fd48553eb4c229035478fa6fbb5bf.tar.gz
historical-46663f19413fd48553eb4c229035478fa6fbb5bf.tar.bz2
historical-46663f19413fd48553eb4c229035478fa6fbb5bf.zip
Version bump.
Package-Manager: portage-2.2_rc60/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/pngcrush/pngcrush-1.7.6.ebuild')
-rw-r--r--media-gfx/pngcrush/pngcrush-1.7.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/pngcrush/pngcrush-1.7.6.ebuild b/media-gfx/pngcrush/pngcrush-1.7.6.ebuild
new file mode 100644
index 000000000000..9ca6ce8581fb
--- /dev/null
+++ b/media-gfx/pngcrush/pngcrush-1.7.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngcrush/pngcrush-1.7.6.ebuild,v 1.1 2009/12/21 21:04:42 spatz Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+MY_P="${P}-nolib"
+
+DESCRIPTION="Portable Network Graphics (PNG) optimizing utility"
+HOMEPAGE="http://pmt.sourceforge.net/pngcrush/"
+SRC_URI="mirror://sourceforge/pmt/${MY_P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libpng
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cp "${FILESDIR}/Makefile" "${S}" || die
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed."
+ dohtml ChangeLog.html || die
+}