summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2006-05-20 17:29:13 +0000
committerJonathan Smith <smithj@gentoo.org>2006-05-20 17:29:13 +0000
commitb11ebac63aacf9655646e79614f411eb70b68db9 (patch)
tree437ea260f6f79b9beaf6acb1d68b5766e40ed797 /media-gfx/xloadimage/xloadimage-4.1-r4.ebuild
parentStable on ppc. bug 129091 (diff)
downloadhistorical-b11ebac63aacf9655646e79614f411eb70b68db9.tar.gz
historical-b11ebac63aacf9655646e79614f411eb70b68db9.tar.bz2
historical-b11ebac63aacf9655646e79614f411eb70b68db9.zip
export CC for cross compiles
Package-Manager: portage-2.0.54
Diffstat (limited to 'media-gfx/xloadimage/xloadimage-4.1-r4.ebuild')
-rw-r--r--media-gfx/xloadimage/xloadimage-4.1-r4.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild b/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild
index 5707669a9e7e..a6aa1e91c9c4 100644
--- a/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild
+++ b/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild,v 1.14 2006/01/18 23:02:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r4.ebuild,v 1.15 2006/05/20 17:29:13 smithj Exp $
-inherit alternatives eutils flag-o-matic
+inherit alternatives eutils flag-o-matic toolchain-funcs
MY_P="${P/-/.}"
S=${WORKDIR}/${MY_P}
@@ -53,6 +53,12 @@ src_unpack() {
chmod +x "${S}"/configure
}
+src_compile() {
+ tc-export CC
+ econf || die
+ emake || die
+}
+
src_install() {
dobin xloadimage || die
dobin uufilter || die