summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-25 13:07:11 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-25 13:07:11 +0000
commitbf7a7034a0ae7c3fd5e7b8129eb22c7b4723ba06 (patch)
tree815f05c443976c6fee0c73fc906e96c199928886 /media-gfx/xsane
parentFixed make install to become make install || die (diff)
downloadhistorical-bf7a7034a0ae7c3fd5e7b8129eb22c7b4723ba06.tar.gz
historical-bf7a7034a0ae7c3fd5e7b8129eb22c7b4723ba06.tar.bz2
historical-bf7a7034a0ae7c3fd5e7b8129eb22c7b4723ba06.zip
touchups
Diffstat (limited to 'media-gfx/xsane')
-rw-r--r--media-gfx/xsane/files/digest-xsane-0.891
-rw-r--r--media-gfx/xsane/xsane-0.86-r1.ebuild28
-rw-r--r--media-gfx/xsane/xsane-0.89.ebuild39
-rw-r--r--media-gfx/xsane/xsane-0.90.ebuild32
4 files changed, 31 insertions, 69 deletions
diff --git a/media-gfx/xsane/files/digest-xsane-0.89 b/media-gfx/xsane/files/digest-xsane-0.89
deleted file mode 100644
index 194708c8666f..000000000000
--- a/media-gfx/xsane/files/digest-xsane-0.89
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b8cee4abda9b0fc8e2d533b11f37fac4 xsane-0.89.tar.gz 2360833
diff --git a/media-gfx/xsane/xsane-0.86-r1.ebuild b/media-gfx/xsane/xsane-0.86-r1.ebuild
index fee97c4bbe72..2069b9a63bf7 100644
--- a/media-gfx/xsane/xsane-0.86-r1.ebuild
+++ b/media-gfx/xsane/xsane-0.86-r1.ebuild
@@ -1,34 +1,34 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.86-r1.ebuild,v 1.7 2003/02/13 12:38:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.86-r1.ebuild,v 1.8 2003/04/25 13:07:11 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="XSane is a graphical scanning frontend"
+DESCRIPTION="graphical scanning frontend"
SRC_URI="http://www.xsane.org/download/${P}.tar.gz"
-HOMEPAGE="http://www.xsane.org"
+HOMEPAGE="http://www.xsane.org/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
+IUSE="nls jpeg png tiff"
-DEPEND="media-gfx/sane-backends =x11-libs/gtk+-1.2*"
+DEPEND="media-gfx/sane-backends
+ =x11-libs/gtk+-1.2*"
src_compile() {
- local myconf
- use nls || myconf="${myconf} --disable-nls"
- use jpeg || myconf="${myconf} --disable-jpeg"
- use png || myconf="${myconf} --disable-png"
- use tiff || myconf="${myconf} --disable-tiff"
-
- econf ${myconf} || die
+ econf \
+ `use_enable nls` \
+ `use_enable jpeg` \
+ `use_enable png` \
+ `use_enable tiff` \
+ || die
make || die
}
-src_install () {
+src_install() {
einstall || die
dodoc xsane.[A-Z]*
dohtml -r doc
-
+
# link xsane so it is seen as a plugin in gimp
if [ -d /usr/lib/gimp/1.2 ]; then
dodir /usr/lib/gimp/1.2/plug-ins
diff --git a/media-gfx/xsane/xsane-0.89.ebuild b/media-gfx/xsane/xsane-0.89.ebuild
deleted file mode 100644
index 67483e20a29c..000000000000
--- a/media-gfx/xsane/xsane-0.89.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.89.ebuild,v 1.2 2003/02/13 12:39:00 vapier Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="XSane is a graphical scanning frontend"
-SRC_URI="http://www.xsane.org/download/${P}.tar.gz"
-HOMEPAGE="http://www.xsane.org"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc"
-
-DEPEND="media-gfx/sane-backends =x11-libs/gtk+-1.2*"
-
-src_compile() {
- local myconf
- use nls || myconf="${myconf} --disable-nls"
- use jpeg || myconf="${myconf} --disable-jpeg"
- use png || myconf="${myconf} --disable-png"
- use tiff || myconf="${myconf} --disable-tiff"
- econf ${myconf} || die
- emake || die
-}
-
-src_install () {
- einstall || die
- dodoc xsane.[A-Z]*
- dohtml -r doc
- # link xsane so it is seen as a plugin in gimp
- if [ -d /usr/lib/gimp/1.2 ]; then
- dodir /usr/lib/gimp/1.2/plug-ins
- dosym /usr/bin/xsane /usr/lib/gimp/1.2/plug-ins
- fi
- if [ -d /usr/lib/gimp/1.3 ]; then
- dodir /usr/lib/gimp/1.3/plug-ins
- dosym /usr/bin/xsane /usr/lib/gimp/1.3/plug-ins
- fi
-}
diff --git a/media-gfx/xsane/xsane-0.90.ebuild b/media-gfx/xsane/xsane-0.90.ebuild
index 05739d7307e5..aa2afe8fbbe7 100644
--- a/media-gfx/xsane/xsane-0.90.ebuild
+++ b/media-gfx/xsane/xsane-0.90.ebuild
@@ -1,36 +1,38 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.90.ebuild,v 1.3 2003/02/13 12:39:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.90.ebuild,v 1.4 2003/04/25 13:07:11 vapier Exp $
-IUSE="gtk2"
-S=${WORKDIR}/${P}
-DESCRIPTION="XSane is a graphical scanning frontend"
+DESCRIPTION="graphical scanning frontend"
SRC_URI="http://www.xsane.org/download/${P}.tar.gz"
-HOMEPAGE="http://www.xsane.org"
+HOMEPAGE="http://www.xsane.org/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc"
+IUSE="gtk2 nls jpeg png tiff"
DEPEND="media-gfx/sane-backends
- ( gtk2? >=x11-libs/gtk+-2.0 :
- =x11-libs/gtk+-1.2* )"
+ || (
+ gtk2? ( >=x11-libs/gtk+-2.0 )
+ =x11-libs/gtk+-1.2*
+ )"
src_compile() {
- local myconf
- use nls || myconf="${myconf} --disable-nls"
- use jpeg || myconf="${myconf} --disable-jpeg"
- use png || myconf="${myconf} --disable-png"
- use tiff || myconf="${myconf} --disable-tiff"
- use gtk2 || myconf="${myconf} --disable-gtk2"
- econf ${myconf} || die
+ econf \
+ `use_enable nls` \
+ `use_enable jpeg` \
+ `use_enable png` \
+ `use_enable tiff` \
+ `use_enable gtk2` \
+ || die
emake || die
}
-src_install () {
+src_install() {
einstall || die
dodoc xsane.[A-Z]*
dohtml -r doc
+
# link xsane so it is seen as a plugin in gimp
if [ -d /usr/lib/gimp/1.2 ]; then
dodir /usr/lib/gimp/1.2/plug-ins