summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-25 00:10:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-25 00:10:03 +0000
commit13a17428107cc049ccd5da70b93ff644b643f084 (patch)
treeced6a9483a5b52ac3eca3cc311eb7f1abd3a25c0 /media-libs/alsa-lib
parentstable on ia64 (diff)
downloadhistorical-13a17428107cc049ccd5da70b93ff644b643f084.tar.gz
historical-13a17428107cc049ccd5da70b93ff644b643f084.tar.bz2
historical-13a17428107cc049ccd5da70b93ff644b643f084.zip
Added ebuild for alsa 1.0.10_rc1.
Package-Manager: portage-2.0.51.22
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog8
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.10_rc1.ebuild62
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.10_rc11
3 files changed, 70 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 72b3347b4d77..d744a3908bd4 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.123 2005/08/24 19:22:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.124 2005/08/25 00:06:16 flameeyes Exp $
+
+*alsa-lib-1.0.10_rc1 (25 Aug 2005)
+
+ 25 Aug 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-lib-1.0.10_rc1.ebuild:
+ Added ebuild for alsa 1.0.10_rc1.
24 Aug 2005; Aron Griffis <agriffis@gentoo.org> alsa-lib-1.0.9.ebuild:
stable on ia64
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.10_rc1.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.10_rc1.ebuild
new file mode 100644
index 000000000000..6c43e0a483e5
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.10_rc1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.10_rc1.ebuild,v 1.1 2005/08/25 00:06:16 flameeyes Exp $
+
+inherit eutils
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+# -sparc: http://bugtrack.alsa-project.org/alsa-bug/view.php?id=1268
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE="doc jack"
+
+RDEPEND="virtual/alsa
+ >=media-sound/alsa-headers-${PV}"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+PDEPEND="jack? ( =media-plugins/alsa-jack-${PV}* )"
+
+src_compile() {
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ einfo "If you are using an emu10k1 based sound card, and you are upgrading"
+ einfo "from a version of alsalib <1.0.6, you will need to recompile packages"
+ einfo "that link against alsa-lib due to some ABI changes between 1.0.5 and"
+ einfo "1.0.6 unique to that hardware. You can do this by executing:"
+ einfo "revdep-rebuild --soname libasound.so.2"
+ einfo "See the following URL for more information:"
+ einfo "http://bugs.gentoo.org/show_bug.cgi?id=65347"
+ echo
+ ewarn "Please use media-sound/alsa-driver rather than in-kernel drivers as there"
+ ewarn "have been some problems recently with the in-kernel drivers. See bug #87544."
+}
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.10_rc1 b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.10_rc1
new file mode 100644
index 000000000000..79e48302c57d
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.10_rc1
@@ -0,0 +1 @@
+MD5 803c9684af07da50f6de1cc9fb57373c alsa-lib-1.0.10rc1.tar.bz2 706311