summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2010-03-19 01:33:43 +0000
committerMart Raudsepp <leio@gentoo.org>2010-03-19 01:33:43 +0000
commitd6ed307abe97f62a3a4694bd115c612c538d9ffe (patch)
tree2963037e40f31950f570418dc32e423163a15a98 /media-libs/gst-plugins-base
parentVersion bump with the following most noteworthy upstream changes: Registry pl... (diff)
downloadhistorical-d6ed307abe97f62a3a4694bd115c612c538d9ffe.tar.gz
historical-d6ed307abe97f62a3a4694bd115c612c538d9ffe.tar.bz2
historical-d6ed307abe97f62a3a4694bd115c612c538d9ffe.zip
Version bump with the following most noteworthy upstream changes: Many improvements and refactoring to playbin2. ISO-639 language code utility functions in libgsttag (via iso-codes). DKS and QTtext subtitle format support in subparse. Bug fixes, performance improvements.
Package-Manager: portage-2.2_rc60/cvs/Linux x86_64
Diffstat (limited to 'media-libs/gst-plugins-base')
-rw-r--r--media-libs/gst-plugins-base/ChangeLog12
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.28.ebuild42
2 files changed, 53 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-base/ChangeLog b/media-libs/gst-plugins-base/ChangeLog
index 085c7bb6362d..b0be19af92f9 100644
--- a/media-libs/gst-plugins-base/ChangeLog
+++ b/media-libs/gst-plugins-base/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-libs/gst-plugins-base
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.119 2010/01/15 09:28:03 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.120 2010/03/19 01:33:43 leio Exp $
+
+*gst-plugins-base-0.10.28 (19 Mar 2010)
+
+ 19 Mar 2010; Mart Raudsepp <leio@gentoo.org>
+ +gst-plugins-base-0.10.28.ebuild:
+ Version bump with the following most noteworthy upstream changes:
+ Many improvements and refactoring to playbin2.
+ ISO-639 language code utility functions in libgsttag (via iso-codes).
+ DKS and QTtext subtitle format support in subparse.
+ Bug fixes, performance improvements.
15 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
gst-plugins-base-0.10.25.ebuild:
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.28.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.28.ebuild
new file mode 100644
index 000000000000..52fde227e607
--- /dev/null
+++ b/media-libs/gst-plugins-base/gst-plugins-base-0.10.28.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.28.ebuild,v 1.1 2010/03/19 01:33:43 leio Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-base gst-plugins10 gnome2 flag-o-matic eutils
+# libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.18
+ >=media-libs/gstreamer-0.10.28
+ >=dev-libs/liboil-0.3.14
+ dev-libs/libxml2
+ app-text/iso-codes
+ !<media-libs/gst-plugins-bad-0.10.10"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.11.5 )
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS README RELEASE"
+
+src_compile() {
+ # gst doesnt handle opts well, last tested with 0.10.15
+ strip-flags
+ replace-flags "-O3" "-O2"
+
+ gst-plugins-base_src_configure \
+ --disable-introspection \
+ $(use_enable nls)
+ emake || die "emake failed."
+}
+
+src_install() {
+ gnome2_src_install
+}