summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-21 09:26:45 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-21 09:26:45 +0000
commit6f000778d81b0c9f5cd331d8470368a6def01d3c (patch)
tree54e057cf2fc12c6126b7fd7a990a06c763076346 /media-libs/imlib
parenthtml documentation no longer gzipped (diff)
downloadhistorical-6f000778d81b0c9f5cd331d8470368a6def01d3c.tar.gz
historical-6f000778d81b0c9f5cd331d8470368a6def01d3c.tar.bz2
historical-6f000778d81b0c9f5cd331d8470368a6def01d3c.zip
not gzipping html docs anymore
Diffstat (limited to 'media-libs/imlib')
-rw-r--r--media-libs/imlib/ChangeLog9
-rw-r--r--media-libs/imlib/files/digest-imlib-1.9.13-r11
-rw-r--r--media-libs/imlib/imlib-1.9.13-r1.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/media-libs/imlib/ChangeLog b/media-libs/imlib/ChangeLog
index 621c0f867cd3..86c5d4d304d7 100644
--- a/media-libs/imlib/ChangeLog
+++ b/media-libs/imlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/imlib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib/ChangeLog,v 1.2 2002/03/17 21:45:35 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib/ChangeLog,v 1.3 2002/03/21 09:26:45 seemant Exp $
+
+*imlib-1.9.13-r1 (21 Mar 2002)
+
+ 21 Mar 2002; Seemant Kulleen <seemant@gentoo.org> imlib-1.9.13-r1.ebuild :
+
+ stefan@mdy.univie.ac.at pointed out the fact that html documentation gets
+ gzipped. This is fixed now.
*imlib-1.9.13 (16 Mar 2002)
diff --git a/media-libs/imlib/files/digest-imlib-1.9.13-r1 b/media-libs/imlib/files/digest-imlib-1.9.13-r1
new file mode 100644
index 000000000000..d40c6d3416e5
--- /dev/null
+++ b/media-libs/imlib/files/digest-imlib-1.9.13-r1
@@ -0,0 +1 @@
+MD5 8ab3f6ea596f731d54c18385bcc3525f imlib-1.9.13.tar.gz 752512
diff --git a/media-libs/imlib/imlib-1.9.13-r1.ebuild b/media-libs/imlib/imlib-1.9.13-r1.ebuild
new file mode 100644
index 000000000000..37de3574c81d
--- /dev/null
+++ b/media-libs/imlib/imlib-1.9.13-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib/imlib-1.9.13-r1.ebuild,v 1.1 2002/03/21 09:26:45 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Imlib is a general Image loading and rendering library."
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz
+ http://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz
+ ftp://gnome.eazel.com/pub/gnome/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="virtual/glibc
+ >=media-libs/giflib-4.1.0
+ >=media-libs/libpng-1.0.7
+ >=media-libs/tiff-3.5.5
+ >=media-libs/libungif-4.1.0
+ >=sys-libs/zlib-1.1.3-r2
+ >=x11-libs/gtk+-1.2.10-r4
+ virtual/x11"
+
+src_compile() {
+
+ #update libtool to fix "relink" bug
+ libtoolize --copy --force
+ aclocal
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/imlib \
+ || die
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/imlib \
+ install || die
+
+ preplib /usr
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS
+ dohtml doc/*.gif doc/index.html
+}
+