summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2010-05-25 17:24:05 +0000
committerJoseph Jezak <josejx@gentoo.org>2010-05-25 17:24:05 +0000
commitc5985290179c86e41b79f943912b5496b468ec0b (patch)
treecc816792ace9ebd11fd4ff40d3b49ef90f8f3128 /media-libs/libmpeg2/files/libmpeg2-0.5.1-altivec.patch
parentVersion bump. (diff)
downloadhistorical-c5985290179c86e41b79f943912b5496b468ec0b.tar.gz
historical-c5985290179c86e41b79f943912b5496b468ec0b.tar.bz2
historical-c5985290179c86e41b79f943912b5496b468ec0b.zip
Added patch to detect altivec.h correctly.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'media-libs/libmpeg2/files/libmpeg2-0.5.1-altivec.patch')
-rw-r--r--media-libs/libmpeg2/files/libmpeg2-0.5.1-altivec.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/media-libs/libmpeg2/files/libmpeg2-0.5.1-altivec.patch b/media-libs/libmpeg2/files/libmpeg2-0.5.1-altivec.patch
new file mode 100644
index 000000000000..617fe7509951
--- /dev/null
+++ b/media-libs/libmpeg2/files/libmpeg2-0.5.1-altivec.patch
@@ -0,0 +1,16 @@
+--- configure.ac.bak 2010-05-25 17:12:14.756245990 +0000
++++ configure.ac 2010-05-25 17:11:51.629581723 +0000
+@@ -79,11 +79,10 @@
+ CFLAGS="$OPT_CFLAGS $TRY_CFLAGS $CFLAGS"
+ AC_MSG_CHECKING([if <altivec.h> is needed])
+ AC_TRY_COMPILE([],
+- [typedef vector int t;
+- vec_ld(0, (unsigned char *)0);],
++ [vector int t; t = vec_add(t,t);],
+ [have_altivec=yes; AC_MSG_RESULT(no)],
+ [AC_TRY_COMPILE([#include <altivec.h>],
+- [typedef vector int t; vec_ld(0, (unsigned char *)0);],
++ [vector int t; t = vec_add(t,t);],
+ [AC_DEFINE([HAVE_ALTIVEC_H],,
+ [Define to 1 if you have the <altivec.h> header.])
+ have_altivec=yes; AC_MSG_RESULT(yes)],