summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-01-31 15:14:18 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-01-31 15:14:18 +0000
commitaba8b11b7cea5ddc933eed60476557af4a47ddef (patch)
tree83403b9bccb6aa573e61983a75eef643858bc07c /media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild
parentUpdating symblink. closes 34648 (diff)
downloadhistorical-aba8b11b7cea5ddc933eed60476557af4a47ddef.tar.gz
historical-aba8b11b7cea5ddc933eed60476557af4a47ddef.tar.bz2
historical-aba8b11b7cea5ddc933eed60476557af4a47ddef.zip
Updating symblink. closes 34648
Diffstat (limited to 'media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild')
-rw-r--r--media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild b/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..fadc6440c0cf
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild,v 1.1 2004/01/31 15:13:51 mholzer Exp $
+
+inherit libtool flag-o-matic gcc
+
+DESCRIPTION="the Ogg Vorbis sound file format library"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+SRC_URI="http://www.vorbis.com/files/${PV}/unix/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ~amd64 ~mips sparc hppa alpha ia64"
+
+DEPEND=">=media-libs/libogg-1.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Fix a gcc crash. With the new atexit patch to gcc, it
+ # seems it does not handle -mno-ieee-fp very well.
+ sed -i -e "s:-mno-ieee-fp::g" configure
+}
+
+src_compile() {
+ elibtoolize
+
+ # Cannot compile with sse2 support it would seem #36104
+ use x86 && [ $(gcc-major-version) -eq 3 ] && append-flags -mno-sse2
+
+ # take out -fomit-frame-pointer from CFLAGS if k6-2
+ is-flag -march=k6-3 && filter-flags -fomit-frame-pointer
+ is-flag -march=k6-2 && filter-flags -fomit-frame-pointer
+ is-flag -march=k6 && filter-flags -fomit-frame-pointer
+
+ # over optimization causes horrible audio artifacts #26463
+ filter-flags -march=pentium?
+
+ # gcc on hppa causes issues when assembling
+ use hppa && replace-flags -march=2.0 -march=1.0
+
+ # Make prelink work properly
+ append-flags -fPIC
+ append-ldflags -fPIC
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dosym /usr/lib/libvorbisfile.so.3.1.0 /usr/lib/libvorbisfile.so.0
+ dosym /usr/lib/libvorbisenc.so.2.0.0 /usr/lib/libvorbisenc.so.0
+
+ rm -rf ${D}/usr/share/doc
+ dodoc AUTHORS COPYING README todo.txt
+ docinto txt
+ dodoc doc/*.txt
+ dohtml -r doc
+}