summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-16 15:13:49 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-16 15:13:49 +0000
commit4e1fe2279a51dece5aeb46cdf19103018ce8aa5f (patch)
tree3a435387f7668f444ca7094ebe3955a51681ff5b /media-libs/svgalib/files
parentVersion bump. Minor modification (see ChangeLog) (diff)
downloadhistorical-4e1fe2279a51dece5aeb46cdf19103018ce8aa5f.tar.gz
historical-4e1fe2279a51dece5aeb46cdf19103018ce8aa5f.tar.bz2
historical-4e1fe2279a51dece5aeb46cdf19103018ce8aa5f.zip
userpriv fix
Diffstat (limited to 'media-libs/svgalib/files')
-rw-r--r--media-libs/svgalib/files/svgalib-1.4.3-userpriv.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/svgalib/files/svgalib-1.4.3-userpriv.patch b/media-libs/svgalib/files/svgalib-1.4.3-userpriv.patch
new file mode 100644
index 000000000000..a20329957284
--- /dev/null
+++ b/media-libs/svgalib/files/svgalib-1.4.3-userpriv.patch
@@ -0,0 +1,42 @@
+diff -u -r svgalib-1.4.3old/demos/Makefile svgalib-1.4.3/demos/Makefile
+--- svgalib-1.4.3old/demos/Makefile 2000-08-06 11:30:21.000000000 +0100
++++ svgalib-1.4.3/demos/Makefile 2003-03-16 14:53:11.000000000 +0000
+@@ -44,21 +44,15 @@
+
+ .c:
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $* $*.c $(LIBS)
+- chown 0 $*
+- chmod 4755 $*
+
+ rwpage: rwpage.pp
+ $(PC) -Rintel rwpage.pp
+
+ testaccel: testaccel.c
+ $(CC) $(CFLAGS) $(LDFLAGS) -o testaccel testaccel.c $(LIBS) -lm
+- chown 0 testaccel
+- chmod 4755 testaccel
+
+ accel: accel.c
+ $(CC) $(CFLAGS) $(LDFLAGS) -o accel accel.c $(LIBS) -lm
+- chown 0 accel
+- chmod 4755 accel
+
+ clean: cleanbin
+ rm -f .depend *.o *~ *.bak
+diff -u -r svgalib-1.4.3old/threeDKit/Makefile svgalib-1.4.3/threeDKit/Makefile
+--- svgalib-1.4.3old/threeDKit/Makefile 1998-04-15 19:50:24.000000000 +0100
++++ svgalib-1.4.3/threeDKit/Makefile 2003-03-16 14:53:58.000000000 +0000
+@@ -39,13 +39,9 @@
+
+ plane: planukit.o planinit.o $(OBJECTS) $(LVGADEP)
+ $(CC) $(LDFLAGS) -o plane planukit.o planinit.o $(OBJECTS) $(LIBS)
+- chown root plane
+- chmod u+s plane
+
+ wrapdemo: wrapdemo.o $(OBJECTS) $(LVGADEP)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o wrapdemo wrapdemo.c $(OBJECTS) $(LIBS)
+- chown root wrapdemo
+- chmod u+s wrapdemo
+
+ .c.o:
+ $(CC) $(CFLAGS) -c -o $*.o $<