summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-04-30 02:08:57 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-04-30 02:08:57 +0000
commit2514eb65182a902941f778b44d5bc812745e3cc1 (patch)
treecebea5371d7b7e17732450a5ed5f95b55b7bf228 /media-libs/xine-lib
parentFixed the format of the X dependency line in pmud-0.10.1-r1.ebuild (diff)
downloadhistorical-2514eb65182a902941f778b44d5bc812745e3cc1.tar.gz
historical-2514eb65182a902941f778b44d5bc812745e3cc1.tar.bz2
historical-2514eb65182a902941f778b44d5bc812745e3cc1.zip
Disable drx3 support because it, apparently, is broken in xine.
Diffstat (limited to 'media-libs/xine-lib')
-rw-r--r--media-libs/xine-lib/ChangeLog8
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-0.9.9-r11
-rw-r--r--media-libs/xine-lib/xine-lib-0.9.9-r1.ebuild74
3 files changed, 81 insertions, 2 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 6d0b0029489f..d1dd235c3142 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,8 +1,12 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.5 2002/04/29 00:00:33 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.6 2002/04/30 02:08:57 agenkin Exp $
-*xine-lib-0.9.9 (29 Apr 2002)
+*xine-lib-0.9.9-r1 (29 Apr 2002)
+
+ 29 Apr 2002; Arcady Genkin <agenkin@thpoon.com> xine-lib-0.9.9-r1.ebuld :
+
+ Disable drx3 support because it breaks build on some systems.
*xine-lib-0.9.7-r2 (12 Apr 2002)
diff --git a/media-libs/xine-lib/files/digest-xine-lib-0.9.9-r1 b/media-libs/xine-lib/files/digest-xine-lib-0.9.9-r1
new file mode 100644
index 000000000000..0020fb7cc1b1
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-0.9.9-r1
@@ -0,0 +1 @@
+MD5 fd628882e9140311868f28da929fbd75 xine-lib-0.9.9.tar.gz 1986745
diff --git a/media-libs/xine-lib/xine-lib-0.9.9-r1.ebuild b/media-libs/xine-lib/xine-lib-0.9.9-r1.ebuild
new file mode 100644
index 000000000000..b957606b69eb
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-0.9.9-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-0.9.9-r1.ebuild,v 1.1 2002/04/30 02:08:57 agenkin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+SRC_URI="http://xine.sourceforge.net/files/xine-lib-${PV}.tar.gz"
+HOMEPAGE="http://xine.sourceforge.net/"
+
+DEPEND="X? ( virtual/x11 )
+ avi? ( >=media-libs/win32codecs-0.50
+ media-libs/divx4linux )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-0.0.3.3
+ >=media-libs/libdvdread-0.9.2 )
+ arts? ( kde-base/kdelibs )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ oggvorbis? ( media-libs/libvorbis )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+
+src_compile() {
+
+ libtoolize --copy --force
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use esd || myconf="${myconf} --disable-esd --disable-esdtest"
+ use nls || myconf="${myconf} --disable-nls"
+ use alsa || myconf="${myconf} --disable-alsa --disable-alsatest"
+ use arts || myconf="${myconf} --disable-arts --disable-artstest"
+ use aalib || myconf="${myconf} --disable-aalib --disable-aalibtest"
+
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-oggtest --disable-vorbis --disable-vorbistest"
+
+ use avi \
+ && myconf="${myconf} --with-w32-path=/usr/lib/win32" \
+ || myconf="${myconf} --disable-asf"
+
+ # This is ``fixes'' compilation problems when em8300 libs installed
+ # The proper fix is to follow.
+ myconf="${myconf} --disable-dxr3 --disable-dxr3test"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF}/html \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+ cd ${S}/doc
+ dodoc dataflow.dia README*
+
+}