summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-19 14:25:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-19 14:25:35 +0000
commitaa8c3b87bd237c6689ca4eeddfedee153e69546e (patch)
treefcfc293d837ec4a8f31d7e50e8ac69ef39c6671b /media-libs/xvid/xvid-1.1.0-r1.ebuild
parentVersion bumped. Fixed QA issue. (diff)
downloadhistorical-aa8c3b87bd237c6689ca4eeddfedee153e69546e.tar.gz
historical-aa8c3b87bd237c6689ca4eeddfedee153e69546e.tar.bz2
historical-aa8c3b87bd237c6689ca4eeddfedee153e69546e.zip
Remove old and unused versions
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26.6 x86_64
Diffstat (limited to 'media-libs/xvid/xvid-1.1.0-r1.ebuild')
-rw-r--r--media-libs/xvid/xvid-1.1.0-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/media-libs/xvid/xvid-1.1.0-r1.ebuild b/media-libs/xvid/xvid-1.1.0-r1.ebuild
deleted file mode 100644
index 8b8154fa52da..000000000000
--- a/media-libs/xvid/xvid-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/xvid-1.1.0-r1.ebuild,v 1.15 2007/11/27 18:53:20 zzam Exp $
-
-inherit eutils fixheadtails autotools
-
-MY_P=${PN}core-${PV/_beta/-beta}
-DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution"
-HOMEPAGE="http://www.xvid.org/"
-SRC_URI="http://downloads.xvid.org/downloads/${MY_P}.tar.bz2
- mirror://gentoo/${PN}-1.1.0-noexec-stack.patch.bz2
- mirror://gentoo/${P}-textrel-2.patch.bz2"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="alpha amd64 arm hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc altivec"
-
-DEPEND="x86? ( >=dev-lang/nasm-0.98.36 )
- amd64? ( dev-lang/yasm )"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}/build/generic
-
-src_unpack() {
- unpack ${A}
-
- cd "${WORKDIR}"/${MY_P}
- epatch "${FILESDIR}/${PN}-1.1.0_beta2-altivec.patch"
- epatch "${WORKDIR}/${PN}-1.1.0-noexec-stack.patch"
- epatch "${FILESDIR}/${P}-3dnow.patch"
- epatch "${DISTDIR}/${P}-textrel-2.patch.bz2"
-
- cd "${S}"
- eautoreconf
-}
-
-src_compile() {
- econf $(use_enable altivec) || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
-
- cd "${S}"/../../
- dodoc AUTHORS ChangeLog README TODO doc/*
-
- if [[ ${CHOST} == *-darwin* ]]; then
- local mylib=$(basename $(ls "${D}"/usr/$(get_libdir)/libxvidcore.*.dylib))
- dosym ${mylib} /usr/$(get_libdir)/libxvidcore.dylib
- else
- local mylib=$(basename $(ls "${D}"/usr/$(get_libdir)/libxvidcore.so*))
- dosym ${mylib} /usr/$(get_libdir)/libxvidcore.so
- dosym ${mylib} /usr/$(get_libdir)/${mylib/.1}
- fi
-
- if use doc ; then
- dodoc CodingStyle doc/README
- docinto examples
- dodoc examples/*
- fi
-}