summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-04-05 11:54:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-04-05 11:54:04 +0000
commit6d68d81fc5b7be85924a9c198f81b49048fadbef (patch)
treea7045f603c0a5c5d0c8162af966f03b5ae9a1d30 /media-plugins/live/live-2009.06.02.ebuild
parentVersion bump wrt bug #376047. (diff)
downloadhistorical-6d68d81fc5b7be85924a9c198f81b49048fadbef.tar.gz
historical-6d68d81fc5b7be85924a9c198f81b49048fadbef.tar.bz2
historical-6d68d81fc5b7be85924a9c198f81b49048fadbef.zip
remove old
Package-Manager: portage-2.2.0_alpha99/cvs/Linux x86_64
Diffstat (limited to 'media-plugins/live/live-2009.06.02.ebuild')
-rw-r--r--media-plugins/live/live-2009.06.02.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/media-plugins/live/live-2009.06.02.ebuild b/media-plugins/live/live-2009.06.02.ebuild
deleted file mode 100644
index a9802e3f4103..000000000000
--- a/media-plugins/live/live-2009.06.02.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2009.06.02.ebuild,v 1.8 2010/01/06 16:55:17 ranger Exp $
-
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="Source-code libraries for standards-based RTP/RTCP/RTSP multimedia streaming, suitable for embedded and/or low-cost streaming applications"
-HOMEPAGE="http://www.live555.com/"
-SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-S="${WORKDIR}"
-
-# Alexis Ballier <aballier@gentoo.org>
-# Be careful, bump this everytime you bump the package and the ABI has changed.
-# If you don't know, ask someone.
-LIVE_ABI_VERSION=3
-
-src_unpack() {
- unpack ${A}
- cd "${WORKDIR}"
-
- cp -pPR live live-shared
- mv live live-static
-
- cp "${FILESDIR}/config.gentoo" live-static
- cp "${FILESDIR}/config.gentoo-so" live-shared
-}
-
-src_compile() {
- tc-export CC CXX LD
-
- cd "${WORKDIR}/live-static"
-
- einfo "Beginning static library build"
- ./genMakefiles gentoo
- emake -j1 LINK_OPTS="-L. $(raw-ldflags)" TESTPROGS_APP="" MEDIA_SERVER_APP="" || die "failed to build static libraries"
-
- einfo "Beginning programs build"
- cd "${WORKDIR}/live-static/testProgs"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
- cd "${WORKDIR}/live-static/mediaServer"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build the mediaserver"
-
- cd "${WORKDIR}/live-shared"
- einfo "Beginning shared library build"
- ./genMakefiles gentoo-so
- emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="so.${LIVE_ABI_VERSION}" TESTPROGS_APP="" MEDIA_SERVER_APP="" || die "failed to build shared libraries"
-}
-
-src_install() {
- for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
- dolib.a live-static/${library}/lib${library}.a
- dolib.so live-shared/${library}/lib${library}.so.${LIVE_ABI_VERSION}
- dosym lib${library}.so.${LIVE_ABI_VERSION} /usr/$(get_libdir)/lib${library}.so
-
- insinto /usr/include/${library}
- doins live-shared/${library}/include/*h
- done
-
- # Should we really install these?
- find live-static/testProgs -type f -perm +111 -print0 | \
- xargs -0 dobin
-
- #install included live555MediaServer aplication
- dobin live-static/mediaServer/live555MediaServer
-
- # install docs
- dodoc live-static/README
-}
-
-pkg_postinst() {
- ewarn "If you are upgrading from a version prior to live-2008.02.08"
- ewarn "Please make sure to rebuild applications built against ${PN}"
- ewarn "like vlc or mplayer. ${PN} may have had ABI changes and ${PN}"
- ewarn "support might be broken."
-}