summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-06-13 07:27:48 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-06-13 07:27:48 +0000
commit26a47a7cb13232e56f2c3ed986ff3a36c81d2e75 (patch)
treea71a73332ae657ccc254745dff667337a5172907 /media-plugins/mythnetvision
parentConvert to ruby-ng. (diff)
downloadhistorical-26a47a7cb13232e56f2c3ed986ff3a36c81d2e75.tar.gz
historical-26a47a7cb13232e56f2c3ed986ff3a36c81d2e75.tar.bz2
historical-26a47a7cb13232e56f2c3ed986ff3a36c81d2e75.zip
Populate depends and setting the proper permissions on the scripts being installed
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'media-plugins/mythnetvision')
-rw-r--r--media-plugins/mythnetvision/ChangeLog7
-rw-r--r--media-plugins/mythnetvision/Manifest4
-rw-r--r--media-plugins/mythnetvision/mythnetvision-0.23_p25065.ebuild23
3 files changed, 29 insertions, 5 deletions
diff --git a/media-plugins/mythnetvision/ChangeLog b/media-plugins/mythnetvision/ChangeLog
index 6b5edf75d5a7..600013458d12 100644
--- a/media-plugins/mythnetvision/ChangeLog
+++ b/media-plugins/mythnetvision/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythnetvision
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythnetvision/ChangeLog,v 1.1 2010/06/13 07:06:24 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythnetvision/ChangeLog,v 1.2 2010/06/13 07:27:48 cardoe Exp $
+
+ 13 Jun 2010; Doug Goldstein <cardoe@gentoo.org>
+ mythnetvision-0.23_p25065.ebuild:
+ Populate depends and setting the proper permissions on the scripts being
+ installed
*mythnetvision-0.23_p25065 (13 Jun 2010)
diff --git a/media-plugins/mythnetvision/Manifest b/media-plugins/mythnetvision/Manifest
index 0b592faa7d04..4f5c820b8af0 100644
--- a/media-plugins/mythnetvision/Manifest
+++ b/media-plugins/mythnetvision/Manifest
@@ -1,4 +1,4 @@
DIST mythplugins-0.23_p25065.zip 38057096 RMD160 3cc3394b1637e3c9f4892ff5b1489815f1cc9c93 SHA1 78aff91f525027342585fc7accc8b4f9bac178c0 SHA256 cc1f375772545c316a1f6d432a6c6c490bfacd9404394d09d765b590d6ffd8ee
-EBUILD mythnetvision-0.23_p25065.ebuild 372 RMD160 0ce252fcb1816ebeb784e0acceeab8dfddd4e07b SHA1 72a962a20b04d9850b911bdf40d60819783493b2 SHA256 aadf131c898997f355327f5c7ac367d8e254af7908f9ee4e79c03b3b3193e3ec
-MISC ChangeLog 411 RMD160 1190ec016898be5a2ba0f3af9637908c387df2d3 SHA1 c78ea519720c872d2cab632dcaa752fc5c802079 SHA256 be51c17ba5991b8ac8b11fc425c26c245e6eabaeb863940eacd0e2c47d615c8d
+EBUILD mythnetvision-0.23_p25065.ebuild 800 RMD160 47d7ac27b3771a6fe72e0d0c3b929ae851a0efdf SHA1 ff0628f054abbfc7545e455b913676e12efb4cc2 SHA256 768967797c58c27f4243a52916f1437fb255d966145b89464cba40613a1a5d53
+MISC ChangeLog 585 RMD160 becd9d8213da03d16cc6af87b3f25e8c4c1b3003 SHA1 5e7e3790eea2ee57bf8719ff1fc83e496744efb5 SHA256 fefaa09e5c57c7fb56ae1ab0b063d75279d7156db3d3afd659292b5de3fc7236
MISC metadata.xml 269 RMD160 33e64a5afa2c6e71c9950596ff6e8638b3de9cdf SHA1 f50da859ff1f88373ac693d6f5142b3d186d73bc SHA256 6bbb451e1977103f3dbe853a436dadfdb6cedbc6a9c3638210931f0a62bdc02b
diff --git a/media-plugins/mythnetvision/mythnetvision-0.23_p25065.ebuild b/media-plugins/mythnetvision/mythnetvision-0.23_p25065.ebuild
index 78f7c84d8c68..8044ec376281 100644
--- a/media-plugins/mythnetvision/mythnetvision-0.23_p25065.ebuild
+++ b/media-plugins/mythnetvision/mythnetvision-0.23_p25065.ebuild
@@ -1,10 +1,29 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythnetvision/mythnetvision-0.23_p25065.ebuild,v 1.1 2010/06/13 07:06:24 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythnetvision/mythnetvision-0.23_p25065.ebuild,v 1.2 2010/06/13 07:27:48 cardoe Exp $
EAPI=2
-inherit qt4 mythtv-plugins
+
+PYTHON_DEPEND="2:2.5"
+
+inherit qt4 mythtv-plugins python
DESCRIPTION="MythTV Plugin for watching internet content"
IUSE=""
KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=dev-python/pycurl-7.19.0
+ >=dev-python/imdbpy-3.8
+ >=dev-python/mysql-python-1.2.2
+ media-tv/mythtv[python]
+ media-plugins/mythbrowser
+ www-plugins/adobe-flash"
+DEPEND="media-plugins/mythbrowser"
+
+src_install() {
+ mythtv-plugins_src_install
+
+ # Fix up permissions
+ fperms 755 /usr/share/mythtv/mythnetvision/scripts/*.pl
+ fperms 755 /usr/share/mythtv/mythnetvision/scripts/*.py
+}