summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-20 03:34:30 +0000
committerMax Kalika <max@gentoo.org>2003-10-20 03:34:30 +0000
commitafc904ac0228783d2cb5e882169be5c5ad579f5b (patch)
treefed52e0423ca47affb5be1985e0b2a07f7bcd4f5 /media-plugins/mythvideo
parentBump to version 0.12. Add support for alsa, lirc, and vcd. (diff)
downloadhistorical-afc904ac0228783d2cb5e882169be5c5ad579f5b.tar.gz
historical-afc904ac0228783d2cb5e882169be5c5ad579f5b.tar.bz2
historical-afc904ac0228783d2cb5e882169be5c5ad579f5b.zip
Bump to version 0.12.
Diffstat (limited to 'media-plugins/mythvideo')
-rw-r--r--media-plugins/mythvideo/ChangeLog7
-rw-r--r--media-plugins/mythvideo/Manifest4
-rw-r--r--media-plugins/mythvideo/files/digest-mythvideo-0.121
-rw-r--r--media-plugins/mythvideo/mythvideo-0.12.ebuild62
4 files changed, 72 insertions, 2 deletions
diff --git a/media-plugins/mythvideo/ChangeLog b/media-plugins/mythvideo/ChangeLog
index a2b3e2aa7d90..fd483e8da390 100644
--- a/media-plugins/mythvideo/ChangeLog
+++ b/media-plugins/mythvideo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythvideo
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.4 2003/09/17 06:28:28 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.5 2003/10/20 03:25:23 max Exp $
+
+*mythvideo-0.12 (19 Oct 2003)
+
+ 19 Oct 2003; Max Kalika <max@gentoo.org> mythvideo-0.12.ebuild:
+ Bump to version 0.12.
16 Sep 2003; Max Kalika <max@gentoo.org> mythvideo-0.10.ebuild,
mythvideo-0.11.ebuild:
diff --git a/media-plugins/mythvideo/Manifest b/media-plugins/mythvideo/Manifest
index b3a243dbe960..dfa5f69296b3 100644
--- a/media-plugins/mythvideo/Manifest
+++ b/media-plugins/mythvideo/Manifest
@@ -1,6 +1,8 @@
MD5 900b376ebae322f2db8bb9db0022bb24 mythvideo-0.10.ebuild 1734
+MD5 9bf19b6b01dd3ba2cef1fb43df92e22e mythvideo-0.12.ebuild 1749
MD5 e108d5867e5f2a919a2fa1c6c404fd37 mythvideo-0.11.ebuild 1749
-MD5 c4557789008be320ffec9056ad905b56 ChangeLog 1802
+MD5 be7dd7b42b06585c80de4a37debb592b ChangeLog 1924
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 bdd77fadda8f0eb40802ceb421042c18 files/digest-mythvideo-0.10 67
MD5 1c1055ed7527e3c6e5c556e1f79456bc files/digest-mythvideo-0.11 67
+MD5 8b1f40b48872fd36d6dfd997ee675a30 files/digest-mythvideo-0.12 67
diff --git a/media-plugins/mythvideo/files/digest-mythvideo-0.12 b/media-plugins/mythvideo/files/digest-mythvideo-0.12
new file mode 100644
index 000000000000..e1dab92ea511
--- /dev/null
+++ b/media-plugins/mythvideo/files/digest-mythvideo-0.12
@@ -0,0 +1 @@
+MD5 a9da050d37e08ebd1dfed46ddd9a76af mythvideo-0.12.tar.bz2 229056
diff --git a/media-plugins/mythvideo/mythvideo-0.12.ebuild b/media-plugins/mythvideo/mythvideo-0.12.ebuild
new file mode 100644
index 000000000000..f21218d9e944
--- /dev/null
+++ b/media-plugins/mythvideo/mythvideo-0.12.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.12.ebuild,v 1.1 2003/10/20 03:25:23 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Video player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( media-video/mplayer media-video/xine-ui )
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins videodb/*.sql
+
+ dodoc COPYING README UPGRADING
+ newdoc videodb/README README.db
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythVideo,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/README.db.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}