summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorben Hohn <torbenh@gentoo.org>2003-06-06 13:07:49 +0000
committerTorben Hohn <torbenh@gentoo.org>2003-06-06 13:07:49 +0000
commita51b6fc0f1ec8be8be481a6d2367623f6362601b (patch)
treeb95e58296a6391a9001f4db2d369872f907b3ced /media-plugins/swh-plugins/swh-plugins-0.4.2.ebuild
parentVersion bump and removed the autmatic machine detection which did not work (diff)
downloadhistorical-a51b6fc0f1ec8be8be481a6d2367623f6362601b.tar.gz
historical-a51b6fc0f1ec8be8be481a6d2367623f6362601b.tar.bz2
historical-a51b6fc0f1ec8be8be481a6d2367623f6362601b.zip
Version bump and removed the autmatic machine detection which did not work
Diffstat (limited to 'media-plugins/swh-plugins/swh-plugins-0.4.2.ebuild')
-rw-r--r--media-plugins/swh-plugins/swh-plugins-0.4.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/swh-plugins/swh-plugins-0.4.2.ebuild b/media-plugins/swh-plugins/swh-plugins-0.4.2.ebuild
new file mode 100644
index 000000000000..f87a5e01038d
--- /dev/null
+++ b/media-plugins/swh-plugins/swh-plugins-0.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/swh-plugins-0.4.2.ebuild,v 1.1 2003/06/06 13:07:12 torbenh Exp $
+
+IUSE="alsa"
+DESCRIPTION="Cool GPL'd audio plugins/effects for use with ALSA and LADSPA"
+HOMEPAGE="http://plugin.org.uk"
+SRC_URI="http://plugin.org.uk/releases/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="alsa? ( media-sound/alsa-driver )
+ media-libs/ladspa-sdk
+ dev-libs/fftw"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A} || die
+
+ cd ${S}
+ sed -i '/MACHINE=/s/.*/MACHINE=""/' configure
+}
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING README TODO || die
+}
+
+pkg_postinst() {
+ ewarn "WARNING: You have to be careful when using the "
+ ewarn "swh plugins. Be sure to lower your sound volume "
+ ewarn "and then play around a bit with the plugins so "
+ ewarn "you get a feeling for it. Otherwise your speakers"
+ ewarn "won't like that. "
+}