summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2011-09-17 20:17:15 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2011-09-17 20:17:15 +0000
commit5448efb70b04c57ff618f289cd4796945c1462a2 (patch)
tree5e12916835aa06383af7e9311f1f9c5a182a9ed8 /media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild
parentpmask live ebuild media-plugins/xbmc-addon-xvdr-9999 (diff)
downloadhistorical-5448efb70b04c57ff618f289cd4796945c1462a2.tar.gz
historical-5448efb70b04c57ff618f289cd4796945c1462a2.tar.bz2
historical-5448efb70b04c57ff618f289cd4796945c1462a2.zip
initial ebuild, pmasked for livetime
Package-Manager: portage-2.1.10.11/cvs/Linux i686
Diffstat (limited to 'media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild')
-rw-r--r--media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild b/media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild
new file mode 100644
index 000000000000..9643ea1c0ac6
--- /dev/null
+++ b/media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild,v 1.1 2011/09/17 20:17:15 hd_brummy Exp $
+
+EAPI="4"
+
+inherit git-2 autotools multilib
+
+EGIT_REPO_URI="git://github.com/pipelka/xbmc-addon-xvdr.git"
+
+DESCRIPTION="XBMC addon: add VDR (http://www.cadsoft.de/vdr) as a TV/PVR Backend"
+HOMEPAGE="https://github.com/pipelka/xbmc-addon-xvdr"
+SRC_URI=""
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf --prefix=/usr/$(get_libdir)/xbmc
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_info() {
+ einfo "This add-on requires the installed "media-lugins/vdr-xvdr" plugin on the VDR server."
+ einfo "VDR itself dosn't need any patches or modification to use all the current features."
+ einfo "IMPORTANT:"
+ einfo "Please disable *all* PVR addons *before* running the XVDR addon!"
+}