summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-04-28 17:18:10 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-04-28 17:18:10 +0000
commit1c9fa2efc0b9fc4ade2a2111519598404d3c5f7b (patch)
tree7a21b8c5cbecd1f748ec8416f6d5680b3f8c8be7 /media-sound/alsa-driver
parentupdate to 1.4. Closes 1865 (diff)
downloadhistorical-1c9fa2efc0b9fc4ade2a2111519598404d3c5f7b.tar.gz
historical-1c9fa2efc0b9fc4ade2a2111519598404d3c5f7b.tar.bz2
historical-1c9fa2efc0b9fc4ade2a2111519598404d3c5f7b.zip
Updated the config file for /etc/modules.d because the sound card
modules' names changed.
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r3.ebuild59
-rw-r--r--media-sound/alsa-driver/files/alsa-modules.conf32
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r31
4 files changed, 99 insertions, 1 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 4eae5e5fd005..87a80a88088c 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.5 2002/04/27 19:22:49 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.6 2002/04/28 17:18:10 agenkin Exp $
*alsa-driver-0.9.0_rc1 (27 Apr 2002)
+ 28 Apr 2002; Arcady Genkin <agenkin@thpoon.com>
+ alsa-driver-0.9.0_rc1-r3.ebuild :
+
+ More work on the startup script and updated config file for /etc/modules.d.
+ Be sure to have a look at it and adjust it to your needs.
+
27 Apr 2002; Arcady Genkin <agenkin@thpoon.com>
alsa-driver-0.9.0_rc1-r2.ebuild :
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r3.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r3.ebuild
new file mode 100644
index 000000000000..d0d4cff78f37
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r3.ebuild,v 1.1 2002/04/28 17:18:10 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment variable accordingly
+[ x${ALSA_CARDS} = x ] && ALSA_CARDS=all
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P/_rc/rc}.tar.bz2"
+S=${WORKDIR}/${P/_rc/rc}
+
+#virtual/glibc should depend on specific kernel headers
+DEPEND="sys-devel/autoconf
+ virtual/glibc"
+PROVIDE="virtual/alsa"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux-${KV}" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards=${ALSA_CARDS} \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst () {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You might want to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+}
diff --git a/media-sound/alsa-driver/files/alsa-modules.conf b/media-sound/alsa-driver/files/alsa-modules.conf
new file mode 100644
index 000000000000..6a993e384dba
--- /dev/null
+++ b/media-sound/alsa-driver/files/alsa-modules.conf
@@ -0,0 +1,32 @@
+# Alsa 0.9.X kernel modules' configuration file.
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsa-modules.conf,v 1.1 2002/04/28 17:18:10 agenkin Exp $
+
+# ALSA portion
+alias char-major-116 snd
+# OSS/Free portion
+alias char-major-14 soundcore
+
+##
+## IMPORTANT:
+## You need to customise this section for your specific sound card(s)
+## and then run `update-modules' command.
+## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
+##
+## ALSA portion
+## alias snd-card-0 snd-interwave
+## alias snd-card-1 snd-ens1371
+## OSS/Free portion
+## alias sound-slot-0 snd-card-0
+## alias sound-slot-1 snd-card-1
+##
+
+# OSS/Free portion - card #1
+alias sound-service-0-0 snd-mixer-oss
+alias sound-service-0-1 snd-seq-oss
+alias sound-service-0-3 snd-pcm-oss
+alias sound-service-0-8 snd-seq-oss
+alias sound-service-0-12 snd-pcm-oss
+## OSS/Free portion - card #2
+## alias sound-service-1-0 snd-mixer-oss
+## alias sound-service-1-3 snd-pcm-oss
+## alias sound-service-1-12 snd-pcm-oss
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r3 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r3
new file mode 100644
index 000000000000..ab82b0c07726
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r3
@@ -0,0 +1 @@
+MD5 440feeb7a0932a9f40a059fe78b3d6b2 alsa-driver-0.9.0rc1.tar.bz2 1103418