summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-11 19:42:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-11 19:42:10 +0000
commitecc3a6c93327d13c028540ac3a4ecbaa80319467 (patch)
tree2059c951dd2fb0f1a05d8385fdbffa2dfac28dc1 /media-sound/alsa-headers/alsa-headers-9999.ebuild
parentAdded ~ppc64; bug #150799 (diff)
downloadhistorical-ecc3a6c93327d13c028540ac3a4ecbaa80319467.tar.gz
historical-ecc3a6c93327d13c028540ac3a4ecbaa80319467.tar.bz2
historical-ecc3a6c93327d13c028540ac3a4ecbaa80319467.zip
Add 9999 version that pulls off the Mercurial repository, for when the release versions aren't working with the current kernel.
Package-Manager: portage-2.1.2_pre2-r8
Diffstat (limited to 'media-sound/alsa-headers/alsa-headers-9999.ebuild')
-rw-r--r--media-sound/alsa-headers/alsa-headers-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/alsa-headers/alsa-headers-9999.ebuild b/media-sound/alsa-headers/alsa-headers-9999.ebuild
new file mode 100644
index 000000000000..4130d395cc3c
--- /dev/null
+++ b/media-sound/alsa-headers/alsa-headers-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/alsa-headers-9999.ebuild,v 1.1 2006/10/11 19:42:10 flameeyes Exp $
+
+inherit eutils mercurial
+
+DESCRIPTION="Header files for Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-*"
+IUSE=""
+
+DEPEND=""
+
+EHG_REPO_URI="http://hg.alsa-project.org/alsa-kernel"
+EHG_PROJECT="alsa-driver"
+
+S="${WORKDIR}/alsa-kernel"
+
+# Remove the sound symlink workaround...
+pkg_setup() {
+ if [[ -L "${ROOT}/usr/include/sound" ]]; then
+ rm "${ROOT}/usr/include/sound"
+ fi
+}
+
+src_unpack() {
+ mercurial_src_unpack
+
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.0.6a-user.patch"
+}
+
+src_compile() {
+ einfo "No compilation neccessary"
+}
+
+src_install() {
+ cd "${S}/include"
+ insinto /usr/include/sound
+ doins *.h || die "include failed"
+}