summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-10-04 20:25:59 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-10-04 20:25:59 +0000
commit179179473ff5a0adc535aecb04aee94968deea0f (patch)
tree3767e12ed1bf16b92de6ec6fdb2c7f1ac81be102 /media-sound/apollo
parentmasking media-sound/apollo-1.4.1 (diff)
downloadhistorical-179179473ff5a0adc535aecb04aee94968deea0f.tar.gz
historical-179179473ff5a0adc535aecb04aee94968deea0f.tar.bz2
historical-179179473ff5a0adc535aecb04aee94968deea0f.zip
apollo-1.4.1 ebuild, bug #8649
Diffstat (limited to 'media-sound/apollo')
-rw-r--r--media-sound/apollo/ChangeLog9
-rw-r--r--media-sound/apollo/apollo-1.4.1.ebuild52
-rw-r--r--media-sound/apollo/files/apollo-1.4.1.patch.bz2bin0 -> 2650 bytes
-rw-r--r--media-sound/apollo/files/digest-apollo-1.4.11
4 files changed, 61 insertions, 1 deletions
diff --git a/media-sound/apollo/ChangeLog b/media-sound/apollo/ChangeLog
index c77a6ba6d9f2..4e9a42724557 100644
--- a/media-sound/apollo/ChangeLog
+++ b/media-sound/apollo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/apollo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/apollo/ChangeLog,v 1.2 2002/08/26 13:56:16 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/apollo/ChangeLog,v 1.3 2002/10/04 20:25:59 hannes Exp $
+
+*apollo-1.4.1 (04 Oct 2002)
+
+ 04 Oct 2002; Hannes Mehnert <hannes@gentoo.org> apollo-1.4.1.ebuild,
+ ChangeLog, files/digest-apollo-1.4.1, files/apollo-1.4.1.patch.bz2 :
+
+ version bump, fixed ebuild, will hopefully close bug #8649
*apollo-1.1.1-r1 (1 Feb 2002)
diff --git a/media-sound/apollo/apollo-1.4.1.ebuild b/media-sound/apollo/apollo-1.4.1.ebuild
new file mode 100644
index 000000000000..244cb169319f
--- /dev/null
+++ b/media-sound/apollo/apollo-1.4.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/apollo/apollo-1.4.1.ebuild,v 1.1 2002/10/04 20:25:59 hannes Exp $
+
+#inherit kde-base
+#use kde && inherit kde-base
+#need-kde 3
+
+S=${WORKDIR}/${P}-1
+DESCRIPTION="A Qt-based front-end to mpg123"
+SRC_URI="mirror://sourceforge/apolloplayer/apollo-src-1.4.1-1.tar.bz2"
+HOMEPAGE="http://www.apolloplayer.org"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="media-sound/mpg123
+ media-libs/id3lib
+ media-sound/mad
+ qt? ( x11-libs/qt )
+ kde? ( kde-base/kdelibs )"
+# dev-libs/STLport
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${A}
+ cd ${S}
+ bzip2 -dc ${FILESDIR}/${P}.patch.bz2 | patch || die "Patch failed"
+ mv install.sh install.sh.orig
+ sed -e 's:$PREFIX/local:$PREFIX:g' -e 's:BINDIR=$dir::' \
+ install.sh.orig > install.sh
+}
+
+src_compile() {
+ local myconf
+ myconf="--without-kde"
+# use kde && kdeconf="--with-kde=$KDEDIR" || kdeconf="--without-kde"
+ myconf="$myconf $kdeconf"
+ use qt && myconf="$myconf --with-qt-dir=$QTDIR --with-qmake" || myconf="$myconf --with-tmake"
+# use stl && myconf="$myconf --with-stl" || myconf="$myconf --without-stl"
+# use buffer && myconf="$myconf --enable-buffer" || myconf="$myconf --disable-buffer"
+# use mad && myconf="$myconf --with-mad=/usr/lib"
+ myconf="$myconf --with-mad=/usr/lib"
+ ./configure.sh $myconf
+ gmake || die "Make failed"
+}
+
+src_install () {
+ dodir /usr/bin
+ sh install.sh --prefix=${D}/usr $kdeconf
+}
diff --git a/media-sound/apollo/files/apollo-1.4.1.patch.bz2 b/media-sound/apollo/files/apollo-1.4.1.patch.bz2
new file mode 100644
index 000000000000..db5b97c5a871
--- /dev/null
+++ b/media-sound/apollo/files/apollo-1.4.1.patch.bz2
Binary files differ
diff --git a/media-sound/apollo/files/digest-apollo-1.4.1 b/media-sound/apollo/files/digest-apollo-1.4.1
new file mode 100644
index 000000000000..95b5a4e0f248
--- /dev/null
+++ b/media-sound/apollo/files/digest-apollo-1.4.1
@@ -0,0 +1 @@
+MD5 9a2ba0930d084bb612f17f4f2ffb707b apollo-src-1.4.1-1.tar.bz2 176084