summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-01 04:18:01 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-01 04:18:01 +0000
commit395d2ee98645558777015da6597ed9ed95a5263e (patch)
tree686850fece681c26b5be94a332abca2614d313af /media-sound/cm/cm-2.4.2.ebuild
parentVersion bump. New xml2 USE flag. (diff)
downloadhistorical-395d2ee98645558777015da6597ed9ed95a5263e.tar.gz
historical-395d2ee98645558777015da6597ed9ed95a5263e.tar.bz2
historical-395d2ee98645558777015da6597ed9ed95a5263e.zip
Version bump. Closes bug #39677.
Diffstat (limited to 'media-sound/cm/cm-2.4.2.ebuild')
-rw-r--r--media-sound/cm/cm-2.4.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-sound/cm/cm-2.4.2.ebuild b/media-sound/cm/cm-2.4.2.ebuild
new file mode 100644
index 000000000000..94a99f0ba1e3
--- /dev/null
+++ b/media-sound/cm/cm-2.4.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/cm-2.4.2.ebuild,v 1.1 2004/03/01 04:18:01 eradicator Exp $
+
+DESCRIPTION="Common Music: An object oriented music composition environment in LISP/scheme"
+HOMEPAGE="http://commonmusic.sourceforge.net"
+SRC_URI="mirror://sourceforge/commonmusic/${P}.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=guile-1.6.4"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodir /usr/share/${PN}
+ # the installer part needs the bin dir created
+ dodir /usr/share/${PN}/bin
+ touch ${D}/usr/share/${PN}/bin/.keep
+ dodir /usr/share/${PN}/src
+ insinto /usr/share/${PN}/src
+ doins ${S}/src/*
+ insinto /usr/share/${PN}/src/plotter
+ doins ${S}/src/plotter/*
+ dodir /usr/share/${PN}/etc
+ insinto /usr/share/${PN}/etc
+ doins ${S}/etc/*
+ dodir /usr/share/${PN}/contrib
+ insinto /usr/share/${PN}/contrib
+ doins ${S}/etc/contrib/*
+ dodir /usr/share/${PN}/examples
+ insinto /usr/share/${PN}/examples
+ doins ${S}/etc/examples/*
+ dohtml -r doc/*
+ dodoc ${S}/readme.text ${S}/doc/changelog.text
+}
+
+pkg_postinst() {
+ # when the package is first run it generates the cm script
+ # that will load the necessary source files into guile when run
+ guile -c "(load \"/usr/share/cm/src/cm.scm\")"
+ ln /usr/share/cm/bin/cm /usr/bin/cm
+ chmod +x /usr/bin/cm
+}
+
+#This will break upgrades
+#pkg_prerm() {
+# if [ -e /usr/bin/cm ]; then
+# rm /usr/bin/cm
+# fi
+# if [ -e /usr/share/cm/bin ]; then
+# rm -rf /usr/share/cm/bin
+# fi
+#}