summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-06-22 01:07:04 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-06-22 01:07:04 +0000
commit253ea28d39250ac03063aac6a6ff9689b9b2fd94 (patch)
tree8bb00d5a5629103ef80b384290231db5b4abed4a /media-sound/cvoicecontrol
parentARCH check update (diff)
downloadhistorical-253ea28d39250ac03063aac6a6ff9689b9b2fd94.tar.gz
historical-253ea28d39250ac03063aac6a6ff9689b9b2fd94.tar.bz2
historical-253ea28d39250ac03063aac6a6ff9689b9b2fd94.zip
voice recognition based command input tool
Diffstat (limited to 'media-sound/cvoicecontrol')
-rw-r--r--media-sound/cvoicecontrol/ChangeLog10
-rw-r--r--media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha.ebuild42
-rw-r--r--media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo.diff12
-rw-r--r--media-sound/cvoicecontrol/files/digest-cvoicecontrol-0.9_alpha1
4 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/cvoicecontrol/ChangeLog b/media-sound/cvoicecontrol/ChangeLog
new file mode 100644
index 000000000000..307e072eb3f3
--- /dev/null
+++ b/media-sound/cvoicecontrol/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/cvoicecontrol
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cvoicecontrol/ChangeLog,v 1.1 2002/06/22 01:07:04 george Exp $
+
+*cvoicecontrol-0.9_alpha.ebuild (20 Jun 2002)
+
+ 20 Jun 2002; George Shapovalov <george@gentoo.org> all :
+
+ First submission
+ Ebuild submitted by Marko Mikulicic <marko@seul.org>
diff --git a/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha.ebuild b/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha.ebuild
new file mode 100644
index 000000000000..716337dccfdf
--- /dev/null
+++ b/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha.ebuild,v 1.1 2002/06/22 01:07:04 george Exp $
+
+S=${WORKDIR}/cvoicecontrol-0.9alpha
+A=cvoicecontrol-0.9alpha.tar.bz2
+
+DESCRIPTION="Console based speech recognition system"
+HOMEPAGE="http://www.kiecza.de/daniel/linux/cvoicecontrol/index.html"
+SRC_URI="http://www.kiecza.de/daniel/linux/${A}"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+LICENSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+
+ patch -p0 <${FILESDIR}/${P}-gentoo.diff || die
+
+ #remove "docs" from SUBDIRS in Makefile.in
+ #Makefile will try to install few html files directly under the /usr
+ #much easier to do with dohtml
+ cd ${S}/cvoicecontrol/
+ mv Makefile.in Makefile.in-orig
+ sed -e "s:SUBDIRS = docs:#SUBDIRS = docs:" Makefile.in-orig > Makefile.in
+
+ cd ${S}
+ mv Makefile.in Makefile.in-orig
+ sed -e "s/install-data-am: install-data-local/install-data-am:/" Makefile.in-orig > Makefile.in
+}
+
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ #install documentation
+ dodoc AUTHORS BUGS COPYING ChangeLog FAQ README
+ dohtml cvoicecontrol/docs/en/*.html
+}
diff --git a/media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo.diff b/media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo.diff
new file mode 100644
index 000000000000..c22dbb04d47b
--- /dev/null
+++ b/media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo.diff
@@ -0,0 +1,12 @@
+diff -r -u cvoicecontrol-0.9alpha/cvoicecontrol/cvoicecontrol.c cvoicecontrol-0.9alpha-gentoo/cvoicecontrol/cvoicecontrol.c
+--- cvoicecontrol-0.9alpha/cvoicecontrol/cvoicecontrol.c 2000-02-17 22:59:41.000000000 +0000
++++ cvoicecontrol-0.9alpha-gentoo/cvoicecontrol/cvoicecontrol.c 2002-06-03 23:39:46.000000000 +0000
+@@ -37,6 +37,8 @@
+ #include<sys/select.h>
+ #endif
+
++#include <values.h>
++
+ #include "cvoicecontrol.h"
+
+ #include "model.h"
diff --git a/media-sound/cvoicecontrol/files/digest-cvoicecontrol-0.9_alpha b/media-sound/cvoicecontrol/files/digest-cvoicecontrol-0.9_alpha
new file mode 100644
index 000000000000..fe13822ac56b
--- /dev/null
+++ b/media-sound/cvoicecontrol/files/digest-cvoicecontrol-0.9_alpha
@@ -0,0 +1 @@
+MD5 ebc82a6d15d5450b2b1c25486c2e1602 cvoicecontrol-0.9alpha.tar.bz2 78013