summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2003-01-14 09:02:06 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2003-01-14 09:02:06 +0000
commita95e7e9e04704ee7ce2150d346f99404713a8c96 (patch)
tree16193e2d32964a11992b1e31866637a9cc742d67 /media-sound/darkice
parentupdate, unstable (diff)
downloadhistorical-a95e7e9e04704ee7ce2150d346f99404713a8c96.tar.gz
historical-a95e7e9e04704ee7ce2150d346f99404713a8c96.tar.bz2
historical-a95e7e9e04704ee7ce2150d346f99404713a8c96.zip
new version
Diffstat (limited to 'media-sound/darkice')
-rw-r--r--media-sound/darkice/ChangeLog9
-rw-r--r--media-sound/darkice/darkice-0.12.ebuild52
-rw-r--r--media-sound/darkice/files/darkice-0.12-gentoo.diff35
-rw-r--r--media-sound/darkice/files/digest-darkice-0.121
4 files changed, 95 insertions, 2 deletions
diff --git a/media-sound/darkice/ChangeLog b/media-sound/darkice/ChangeLog
index e65752caa63f..727595afe06f 100644
--- a/media-sound/darkice/ChangeLog
+++ b/media-sound/darkice/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for media-sound/darkice
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/ChangeLog,v 1.1 2002/08/13 18:34:47 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/ChangeLog,v 1.2 2003/01/14 09:02:06 leonardop Exp $
+
+*darkice-0.12 (14 Jan 2003)
+
+ 14 Jan 2003; L. Boshell <leonardop@gentoo.org> : New version. Thanks to
+ Blake Watters for his report (bug #12037).
*darkice-0.10.1 (13 Aug 2002)
13 Aug 2002; Arcady Genkin <agenkin@thpoon.com> darkice-0.10.1.ebuild :
- Initial version, submitted by Blake Watters <sbw@ibiblio.org>. \ No newline at end of file
+ Initial version, submitted by Blake Watters <sbw@ibiblio.org>.
diff --git a/media-sound/darkice/darkice-0.12.ebuild b/media-sound/darkice/darkice-0.12.ebuild
new file mode 100644
index 000000000000..34424bba25ea
--- /dev/null
+++ b/media-sound/darkice/darkice-0.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/darkice-0.12.ebuild,v 1.1 2003/01/14 09:02:06 leonardop Exp $
+
+DESCRIPTION="IceCast live streamer delivering Ogg and mp3 streams simulatenously to multiple hosts."
+HOMEPAGE="http://darkice.sourceforge.net/"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="encode oggvorbis"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+DEPEND="encode? ( >=media-sound/lame-1.89 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ local myconf=""
+
+ if [ ! "`use encode`" ] && [ ! "`use oggvorbis`" ]
+ then
+
+ eerror "You need support for mp3 or Ogg Vorbis enconding for this"
+ eerror "package. Please merge again with at least one of the "
+ eerror "\`encode' and \`oggvorbis' USE flags enabled:"
+ eerror
+ eerror " # USE=\"encode\" emerge darkice"
+ eerror " # USE=\"oggvorbis\" emerge darkice"
+ die "Won't build without support for lame nor vorbis"
+ fi
+
+ use encode || myconf="--without-lame"
+ use oggvorbis || myconf="--without-vorbis"
+
+ econf ${myconf}
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall darkicedocdir=${D}/usr/share/doc/${PF} || die
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README TODO
+}
diff --git a/media-sound/darkice/files/darkice-0.12-gentoo.diff b/media-sound/darkice/files/darkice-0.12-gentoo.diff
new file mode 100644
index 000000000000..db57d1bc247a
--- /dev/null
+++ b/media-sound/darkice/files/darkice-0.12-gentoo.diff
@@ -0,0 +1,35 @@
+diff -NurB darkice-0.12/src/MultiThreadedConnector.h darkice-0.12-patched/src/MultiThreadedConnector.h
+--- darkice-0.12/src/MultiThreadedConnector.h 2002-10-19 08:35:21.000000000 -0500
++++ darkice-0.12-patched/src/MultiThreadedConnector.h 2003-01-14 03:29:53.000000000 -0500
+@@ -180,15 +180,6 @@
+ void
+ strip ( void ) throw ( Exception );
+
+- /**
+- * This is the function for each thread.
+- * This function has to return fast
+- *
+- * @param ixSink the index of the sink this thread works on.
+- */
+- void
+- sinkThread( int ixSink );
+-
+ protected:
+
+ /**
+@@ -206,6 +197,15 @@
+ public:
+
+ /**
++ * This is the function for each thread.
++ * This function has to return fast
++ *
++ * @param ixSink the index of the sink this thread works on.
++ */
++ void
++ sinkThread( int ixSink );
++
++ /**
+ * Constructor based on a Source.
+ *
+ * @param source the source to connect to the sinks.
diff --git a/media-sound/darkice/files/digest-darkice-0.12 b/media-sound/darkice/files/digest-darkice-0.12
new file mode 100644
index 000000000000..d8867398096e
--- /dev/null
+++ b/media-sound/darkice/files/digest-darkice-0.12
@@ -0,0 +1 @@
+MD5 a28af863edaab12366a5b66b167b8fd6 darkice-0.12.tar.gz 314628