summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2006-10-01 20:22:52 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2006-10-01 20:22:52 +0000
commit3102c35c298f516540c1185f8ae141adb1abdadf (patch)
tree615089dabeccd7b61bf23e0e21c822c8f4a7824a /media-sound/declick
parentMarked ~ppc-macos (diff)
downloadhistorical-3102c35c298f516540c1185f8ae141adb1abdadf.tar.gz
historical-3102c35c298f516540c1185f8ae141adb1abdadf.tar.bz2
historical-3102c35c298f516540c1185f8ae141adb1abdadf.zip
added LDFLAGS
Package-Manager: portage-2.1.2_pre2
Diffstat (limited to 'media-sound/declick')
-rw-r--r--media-sound/declick/ChangeLog5
-rw-r--r--media-sound/declick/declick-0.6.5.ebuild12
2 files changed, 14 insertions, 3 deletions
diff --git a/media-sound/declick/ChangeLog b/media-sound/declick/ChangeLog
index d451f7b4fb45..6043f42d7250 100644
--- a/media-sound/declick/ChangeLog
+++ b/media-sound/declick/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/declick
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/declick/ChangeLog,v 1.1 2006/02/04 22:49:07 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/declick/ChangeLog,v 1.2 2006/10/01 20:22:52 sbriesen Exp $
+
+ 01 Oct 2006; Stefan Briesenick <sbriesen@gentoo.org> declick-0.6.5.ebuild:
+ added LDFLAGS
*declick-0.6.5 (04 Feb 2006)
diff --git a/media-sound/declick/declick-0.6.5.ebuild b/media-sound/declick/declick-0.6.5.ebuild
index 6f4b08be7bcd..e252fd2c1823 100644
--- a/media-sound/declick/declick-0.6.5.ebuild
+++ b/media-sound/declick/declick-0.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/declick/declick-0.6.5.ebuild,v 1.1 2006/02/04 22:49:07 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/declick/declick-0.6.5.ebuild,v 1.2 2006/10/01 20:22:52 sbriesen Exp $
inherit eutils toolchain-funcs
@@ -14,8 +14,16 @@ KEYWORDS="~x86"
IUSE=""
DEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # add $LDFLAGS to link command
+ sed -i -e "s:\(-o declick\):\$(LDFLAGS) \1:g" Makefile
+}
+
src_compile() {
- emake CC="$(tc-getCC)" COPTS="${CFLAGS}" || die "emake failed"
+ emake CC="$(tc-getCC)" COPTS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {