summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-01 03:00:59 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-01 03:00:59 +0000
commit0146bcc8d71a2e0fecbdc751c3c93b40408dc011 (patch)
tree6d6595ab0d68f7a8e811f062b81c33636a7eda34 /media-sound/gnome-alsamixer
parentnew ebuild. fixes #14354 (diff)
downloadhistorical-0146bcc8d71a2e0fecbdc751c3c93b40408dc011.tar.gz
historical-0146bcc8d71a2e0fecbdc751c3c93b40408dc011.tar.bz2
historical-0146bcc8d71a2e0fecbdc751c3c93b40408dc011.zip
initial release
Diffstat (limited to 'media-sound/gnome-alsamixer')
-rw-r--r--media-sound/gnome-alsamixer/files/digest-gnome-alsamixer-0.9.31
-rw-r--r--media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/gnome-alsamixer/files/digest-gnome-alsamixer-0.9.3 b/media-sound/gnome-alsamixer/files/digest-gnome-alsamixer-0.9.3
new file mode 100644
index 000000000000..6fcb94a6e38d
--- /dev/null
+++ b/media-sound/gnome-alsamixer/files/digest-gnome-alsamixer-0.9.3
@@ -0,0 +1 @@
+MD5 594aec0bebe41833eeb39ecda74ee82c gnome-alsamixer-0.9.3.tar.gz 89296
diff --git a/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild b/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild
new file mode 100644
index 000000000000..bfa3ed50f017
--- /dev/null
+++ b/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild,v 1.1 2003/03/01 03:00:59 liquidx Exp $
+
+IUSE=""
+DESCRIPTION="Gnome 2 based ALSA Mixer"
+HOMEPAGE="http://www.paw.co.za/projects/gnome-alsamixer"
+SRC_URI="ftp://ftp.paw.co.za/pub/PAW/sources/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+RDEPEND=">=media-libs/alsa-lib-0.9.0_rc1
+ >=x11-libs/gtk+-2.0.6
+ >=gnome-base/libgnomeui-2.0.5"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/desktop-file-utils"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die
+}
+
+src_install() {
+
+ # hack to prevent ugly filenames in /usr/share/applications
+ cd ${S}; mv ${PN}.desktop ${PN}.desktop.gentoo
+
+ einstall || die
+
+ # manuall install menu entry
+ insinto /usr/share/applications
+ newins ${PN}.desktop.gentoo ${PN}.desktop
+}