summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-30 18:46:34 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-30 18:46:34 +0000
commitbce0900dbe645c852c1915b79fef2676d84567da (patch)
tree12de7064c945cc45539ca206836b135a4b5c7e65 /media-sound/gnump3d/gnump3d-2.7.ebuild
parentVersion bump closes bug #45773. (diff)
downloadhistorical-bce0900dbe645c852c1915b79fef2676d84567da.tar.gz
historical-bce0900dbe645c852c1915b79fef2676d84567da.tar.bz2
historical-bce0900dbe645c852c1915b79fef2676d84567da.zip
Version bump closes bug #46146.
Diffstat (limited to 'media-sound/gnump3d/gnump3d-2.7.ebuild')
-rw-r--r--media-sound/gnump3d/gnump3d-2.7.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/gnump3d/gnump3d-2.7.ebuild b/media-sound/gnump3d/gnump3d-2.7.ebuild
new file mode 100644
index 000000000000..339ad6bb2e73
--- /dev/null
+++ b/media-sound/gnump3d/gnump3d-2.7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/gnump3d-2.7.ebuild,v 1.1 2004/03/30 18:46:34 eradicator Exp $
+
+DESCRIPTION="A streaming server for MP3, OGG vorbis and other streamable files"
+HOMEPAGE="http://www.gnump3d.org/"
+SRC_URI="http://savannah.gnu.org/download/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="sys-apps/sed"
+
+RDEPEND=">=dev-lang/perl-5.8.0"
+
+LIBDIR=/usr/lib/gnump3d
+
+pkg_setup() {
+ enewuser gnump3d '' '' '' nogroup || die
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/bin
+ for binary in gnump3d-index gnump3d2; do
+ sed -i "s,#!/usr/bin/perl,#!/usr/bin/perl -I${LIBDIR},g" $binary
+ done
+}
+
+src_install() {
+ insinto ${LIBDIR}/gnump3d; doins lib/gnump3d/*.pm
+ insinto ${LIBDIR}/gnump3d/plugins; doins lib/gnump3d/plugins/*.pm
+ insinto ${LIBDIR}/gnump3d/lang; doins lib/gnump3d/lang/*.pm
+ dobin bin/gnump3d2 bin/gnump3d-top bin/gnump3d-index
+ dosym /usr/bin/gnump3d2 /usr/bin/gnump3d
+ doman man/*.1
+ dodir /usr/share/gnump3d; cp -R templates/* ${D}/usr/share/gnump3d/
+ insinto /etc/gnump3d
+ doins etc/mime.types
+ doins etc/gnump3d.conf
+ dosed "s,PLUGINDIR,${LIBDIR},g" /etc/gnump3d/gnump3d.conf
+ dosed 's,^user *= *\(.*\)$,user = gnump3d,g' /etc/gnump3d/gnump3d.conf
+
+ dodoc AUTHORS ChangeLog README COPYING TODO
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PN}.init.d gnump3d
+ dodir /etc/env.d
+ cat >${D}/etc/env.d/50gnump3d <<EOF
+# PERL5LIB="${LIBDIR}"
+EOF
+ dodir /var/log/gnump3d
+ dodir /var/cache/gnump3d/serving
+
+ keepdir /var/log/gnump3d
+ keepdir /var/cache/gnump3d/serving
+
+ touch ${D}/var/cache/gnump3d/song.tags
+ touch ${D}/var/cache/gnump3d/serving/.keep
+}
+
+pkg_postinst() {
+ chown -R gnump3d:nogroup /var/log/gnump3d
+ chown -R gnump3d:nogroup /var/cache/gnump3d
+ while read line; do einfo "${line}"; done <<EOF
+
+Please edit your /etc/gnump3d/gnump3d.conf before running
+/etc/init.d/gnump3d start
+
+EOF
+}