summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2008-08-01 10:49:22 +0000
committerHanno Boeck <hanno@gentoo.org>2008-08-01 10:49:22 +0000
commit5de69b1b187daafcd1715c92d9a7d27042403635 (patch)
treea409db5fc12d5efd7b32b7cd1d8cc316c3a7c007 /media-sound/gpodder/gpodder-0.12.1.ebuild
parentfix digest that was broken due to local incomplete download, bug #233299. (diff)
downloadhistorical-5de69b1b187daafcd1715c92d9a7d27042403635.tar.gz
historical-5de69b1b187daafcd1715c92d9a7d27042403635.tar.bz2
historical-5de69b1b187daafcd1715c92d9a7d27042403635.zip
gpodder bump
Package-Manager: portage-2.2_rc5/cvs/Linux 2.6.26 i686
Diffstat (limited to 'media-sound/gpodder/gpodder-0.12.1.ebuild')
-rw-r--r--media-sound/gpodder/gpodder-0.12.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/gpodder/gpodder-0.12.1.ebuild b/media-sound/gpodder/gpodder-0.12.1.ebuild
new file mode 100644
index 000000000000..52ea8a34535a
--- /dev/null
+++ b/media-sound/gpodder/gpodder-0.12.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gpodder/gpodder-0.12.1.ebuild,v 1.1 2008/08/01 10:49:22 hanno Exp $
+
+inherit distutils
+
+DESCRIPTION="gPodder is a Podcast receiver/catcher written in Python, using GTK."
+HOMEPAGE="http://gpodder.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipod libnotify"
+RESTRICT="test"
+
+RDEPEND="dev-python/feedparser
+ dev-python/pygtk
+ sys-devel/gettext
+ libnotify? ( dev-python/notify-python )
+ >=dev-python/pysqlite-2.4
+ ipod? (
+ || ( dev-python/eyeD3 dev-python/pymad )
+ media-libs/libgpod
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ media-gfx/imagemagick
+ sys-apps/help2man"
+
+pkg_setup() {
+ if use ipod && ! built_with_use media-libs/libgpod python ; then
+ eerror "media-libs/libgpod has to be compiled with USE=python"
+ die "Needed USE-flag for libgpod not found."
+ fi
+ if ! built_with_use 'media-gfx/imagemagick' 'png'; then
+ eerror "You must build imagemagick with png support"
+ die "media-gfx/imagemagick built without png"
+ fi
+}
+
+src_compile() {
+ emake generators || die
+ emake messages || die
+ distutils_src_compile || die
+}