summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-13 18:45:11 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-13 18:45:11 +0000
commita0d6416b3c27acf700548348e5eca0e4fded5238 (patch)
treea1bc8420f2e7abfe9bc1f3a12c0a51b6d8e2f593 /media-sound/lilypond/lilypond-2.14.2.ebuild
parentFix building for PowerPC64 using patch from libffi-discuss ML. (diff)
downloadhistorical-a0d6416b3c27acf700548348e5eca0e4fded5238.tar.gz
historical-a0d6416b3c27acf700548348e5eca0e4fded5238.tar.bz2
historical-a0d6416b3c27acf700548348e5eca0e4fded5238.zip
Add build dep on pkgconfig and respect CFLAGS (bug #383515).
Package-Manager: portage-2.2.0_alpha90/cvs/Linux x86_64
Diffstat (limited to 'media-sound/lilypond/lilypond-2.14.2.ebuild')
-rw-r--r--media-sound/lilypond/lilypond-2.14.2.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/media-sound/lilypond/lilypond-2.14.2.ebuild b/media-sound/lilypond/lilypond-2.14.2.ebuild
index fee6714c387b..7ebdac764722 100644
--- a/media-sound/lilypond/lilypond-2.14.2.ebuild
+++ b/media-sound/lilypond/lilypond-2.14.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.14.2.ebuild,v 1.2 2012/03/12 23:56:52 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.14.2.ebuild,v 1.3 2012/03/13 18:45:11 radhermit Exp $
EAPI="4"
PYTHON_DEPEND="2"
-inherit elisp-common python
+inherit elisp-common python autotools
DESCRIPTION="GNU Music Typesetter"
SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
@@ -27,6 +27,7 @@ DEPEND="${RDEPEND}
app-text/t1utils
dev-lang/perl
dev-texlive/texlive-metapost
+ dev-util/pkgconfig
media-gfx/fontforge
>=sys-apps/texinfo-4.11
>=sys-devel/bison-2.0
@@ -46,6 +47,10 @@ src_prepare() {
if ! use vim-syntax ; then
sed -i -e "s/vim//" GNUmakefile.in || die
fi
+
+ sed -i -e "s/OPTIMIZE -g/OPTIMIZE/" aclocal.m4 || die
+
+ eautoreconf
}
src_configure() {
@@ -55,6 +60,8 @@ src_configure() {
econf \
--with-ncsb-dir=/usr/share/fonts/urw-fonts \
--disable-documentation \
+ --disable-optimising \
+ --disable-pipe \
$(use_enable debug debugging) \
$(use_enable profile profiling)
}