summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2007-02-10 23:35:12 +0000
committerHanno Boeck <hanno@gentoo.org>2007-02-10 23:35:12 +0000
commit562a46e28faa0386fa3ccad82d7d75d5ecc1f06f (patch)
treec17a6fe1c803639008ff65056ea05905aae2c976 /media-sound/moodbar/moodbar-0.1.2.ebuild
parentmoved from USE flag tcltk to tcl, see bug 17808 (diff)
downloadhistorical-562a46e28faa0386fa3ccad82d7d75d5ecc1f06f.tar.gz
historical-562a46e28faa0386fa3ccad82d7d75d5ecc1f06f.tar.bz2
historical-562a46e28faa0386fa3ccad82d7d75d5ecc1f06f.zip
moodbar bump
Package-Manager: portage-2.1.2-r9
Diffstat (limited to 'media-sound/moodbar/moodbar-0.1.2.ebuild')
-rw-r--r--media-sound/moodbar/moodbar-0.1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-sound/moodbar/moodbar-0.1.2.ebuild b/media-sound/moodbar/moodbar-0.1.2.ebuild
new file mode 100644
index 000000000000..f98379792277
--- /dev/null
+++ b/media-sound/moodbar/moodbar-0.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/moodbar/moodbar-0.1.2.ebuild,v 1.1 2007/02/10 23:35:12 hanno Exp $
+
+DESCRIPTION="The moodbar tool and gstreamer plugin for Amarok"
+HOMEPAGE="http://amarok.kde.org/wiki/Moodbar"
+SRC_URI="http://pwsp.net/~qbob/moodbar-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mp3 ogg vorbis flac"
+
+DEPEND=">=media-libs/gst-plugins-base-0.10
+ >=sci-libs/fftw-3.0"
+RDEPEND="${DEPEND}
+ >=media-libs/gst-plugins-good-0.10
+ mp3? ( >=media-plugins/gst-plugins-mad-0.10 )
+ ogg? ( >=media-plugins/gst-plugins-ogg-0.10 )
+ vorbis? ( >=media-plugins/gst-plugins-vorbis-0.10 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10 )"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}