summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-02-19 18:39:37 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-02-19 18:39:37 +0000
commit7d9e59b2912ca75430c9968c9cbf1a70684fb0f7 (patch)
treea31fe205bce7e10c0bbff0c36d5a5b8f6e21fa58 /media-sound/museseq/museseq-0.6.0.ebuild
parentStable on x86 (diff)
downloadhistorical-7d9e59b2912ca75430c9968c9cbf1a70684fb0f7.tar.gz
historical-7d9e59b2912ca75430c9968c9cbf1a70684fb0f7.tar.bz2
historical-7d9e59b2912ca75430c9968c9cbf1a70684fb0f7.zip
Resolving conflict in executable name with media-sound/muse. We instal as lmuse and setup a symlink if muse is not installed. Closes bug #34973.
Diffstat (limited to 'media-sound/museseq/museseq-0.6.0.ebuild')
-rw-r--r--media-sound/museseq/museseq-0.6.0.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/media-sound/museseq/museseq-0.6.0.ebuild b/media-sound/museseq/museseq-0.6.0.ebuild
index fd733866c9c3..48e6d34d58a1 100644
--- a/media-sound/museseq/museseq-0.6.0.ebuild
+++ b/media-sound/museseq/museseq-0.6.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.6.0.ebuild,v 1.2 2003/12/06 23:25:38 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.6.0.ebuild,v 1.3 2004/02/19 18:39:37 eradicator Exp $
inherit virtualx
@@ -36,6 +36,13 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
dodoc COPYING INSTALL README README.softsynth SECURITY TODO
+
+ # Name conflict with media-sound/muse. See bug #34973
+ mv ${D}/usr/bin/muse ${D}/usr/bin/lmuse
+
+ if [ ! -f /usr/bin/muse -o -L /usr/bin/muse ]; then
+ dosym /usr/bin/lmuse /usr/bin/muse
+ fi
}
pkg_postinst() {
@@ -43,7 +50,7 @@ pkg_postinst() {
einfo "Muse has been installed normally. If,"
einfo "you would like to use muse with real time"
einfo "time capabilities for the sequencer then do"
- einfo "chmod 4755 /usr/bin/muse"
+ einfo "chmod 4755 /usr/bin/lmuse"
einfo ""
einfo "Muse can use /dev/rtc if it is compiled in"
einfo "to your kernel, or available as a module."