summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-08-31 23:57:00 +0000
committerChris White <chriswhite@gentoo.org>2004-08-31 23:57:00 +0000
commit7b751750d44c488bcb7ad6bfec221a634dd194b8 (patch)
treefb7071f3f7b40cf99854ce708c1eb6ea0bd49029 /media-sound
parenterror messages; tidy (diff)
downloadhistorical-7b751750d44c488bcb7ad6bfec221a634dd194b8.tar.gz
historical-7b751750d44c488bcb7ad6bfec221a634dd194b8.tar.bz2
historical-7b751750d44c488bcb7ad6bfec221a634dd194b8.zip
Initial import to the tree. Closes Bug #57066.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/shoutcast-trans-bin/ChangeLog11
-rw-r--r--media-sound/shoutcast-trans-bin/Manifest5
-rw-r--r--media-sound/shoutcast-trans-bin/files/digest-shoutcast-trans-bin-0.4.01
-rw-r--r--media-sound/shoutcast-trans-bin/files/shoutcast_trans32
-rw-r--r--media-sound/shoutcast-trans-bin/metadata.xml8
-rw-r--r--media-sound/shoutcast-trans-bin/shoutcast-trans-bin-0.4.0.ebuild59
6 files changed, 116 insertions, 0 deletions
diff --git a/media-sound/shoutcast-trans-bin/ChangeLog b/media-sound/shoutcast-trans-bin/ChangeLog
new file mode 100644
index 000000000000..2a0e80284d1e
--- /dev/null
+++ b/media-sound/shoutcast-trans-bin/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-sound/shoutcast-trans-bin
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shoutcast-trans-bin/ChangeLog,v 1.1 2004/08/31 23:57:00 chriswhite Exp $
+
+*shoutcast-trans-bin-0.4.0 (01 Sep 2004)
+
+ 01 Sep 2004; Chris White <chriswhite@gentoo.org> +metadata.xml,
+ +files/shoutcast_trans, +shoutcast-trans-bin-0.4.0.ebuild:
+ Initial import to the tree. Closes bug #57066. Thanks to Georg Brandl
+ <g.brandl@gmx.net> for posting.
+
diff --git a/media-sound/shoutcast-trans-bin/Manifest b/media-sound/shoutcast-trans-bin/Manifest
new file mode 100644
index 000000000000..ff68b9a29d7c
--- /dev/null
+++ b/media-sound/shoutcast-trans-bin/Manifest
@@ -0,0 +1,5 @@
+MD5 5d18573cd17057e66fcf283aa1744f0f shoutcast-trans-bin-0.4.0.ebuild 2018
+MD5 dbafe0153b3ee5f599d5dbeac4aa3210 metadata.xml 224
+MD5 cf9c420ed79b3db6b1ed77582a91e889 ChangeLog 515
+MD5 9ccef27495f4b1f47acfefdb67ccffab files/digest-shoutcast-trans-bin-0.4.0 67
+MD5 cb5c9645d2b90950ca253dc8ba27c23b files/shoutcast_trans 783
diff --git a/media-sound/shoutcast-trans-bin/files/digest-shoutcast-trans-bin-0.4.0 b/media-sound/shoutcast-trans-bin/files/digest-shoutcast-trans-bin-0.4.0
new file mode 100644
index 000000000000..f5b33c5ba859
--- /dev/null
+++ b/media-sound/shoutcast-trans-bin/files/digest-shoutcast-trans-bin-0.4.0
@@ -0,0 +1 @@
+MD5 8a6341eb30286a796336d9dcf9ffe986 sc_trans_posix_040.tgz 351390
diff --git a/media-sound/shoutcast-trans-bin/files/shoutcast_trans b/media-sound/shoutcast-trans-bin/files/shoutcast_trans
new file mode 100644
index 000000000000..bcaa75dd8249
--- /dev/null
+++ b/media-sound/shoutcast-trans-bin/files/shoutcast_trans
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+depend() {
+ need localmount
+ need shoutcast
+}
+
+checkconfig() {
+ if ! [ -f /etc/shoutcast/sc_trans.conf ] ; then
+ eerror "Configuration file /etc/shoutcast/sc_trans.conf does not exist!"
+ return 1
+ fi
+
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting Shoutcast Trans"
+ start-stop-daemon --start --quiet --exec /opt/shoutcast/sc_trans_linux /etc/shoutcast/sc_trans.conf > /dev/null &
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Shoutcast Trans"
+ start-stop-daemon --stop --quiet --exec /opt/shoutcast/sc_trans_linux
+ eend $?
+}
diff --git a/media-sound/shoutcast-trans-bin/metadata.xml b/media-sound/shoutcast-trans-bin/metadata.xml
new file mode 100644
index 000000000000..ec6a427b666f
--- /dev/null
+++ b/media-sound/shoutcast-trans-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+<maintainer>
+ <email>chriswhite@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-sound/shoutcast-trans-bin/shoutcast-trans-bin-0.4.0.ebuild b/media-sound/shoutcast-trans-bin/shoutcast-trans-bin-0.4.0.ebuild
new file mode 100644
index 000000000000..aa97cc4c1c8b
--- /dev/null
+++ b/media-sound/shoutcast-trans-bin/shoutcast-trans-bin-0.4.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shoutcast-trans-bin/shoutcast-trans-bin-0.4.0.ebuild,v 1.1 2004/08/31 23:57:00 chriswhite Exp $
+
+inherit eutils
+
+SVER="${PV//./}"
+RESTRICT="nomirror nostrip"
+DESCRIPTION="A transcoder that provides a source for shoutcast-server-bin to stream from."
+HOMEPAGE="http://www.shoutcast.com"
+SRC_URI="http://www.shoutcast.com/downloads/sc_trans_posix_${SVER}.tgz"
+LICENSE="shoutcast"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/libc
+media-sound/shoutcast-server-bin"
+S="${WORKDIR}/sc_trans_${SVER}"
+
+src_unpack() {
+ unpack "sc_trans_posix_${SVER}.tgz"
+}
+
+src_install() {
+ # install executable
+ exeinto /opt/shoutcast
+ doexe sc_trans_linux
+
+ # install the init.d file
+ doinitd ${FILESDIR}/shoutcast_trans
+
+ # install sample configuration file
+ dodoc example.lst
+ cp sc_trans.conf sc_trans.conf.example
+ dodoc sc_trans.conf.example
+
+ # install configuration file
+ sed -e "s/LogFile=sc_trans\.log/LogFile=\/dev\/null/" -i sc_trans.conf
+ # filter out some midly offensive stuff in the config file
+ sed -e "s|^StreamTitle=.*|StreamTitle=Example Stream|" -i sc_trans.conf
+ sed -e "s|^StreamURL=.*|StreamURL=http://examplestream.com/|" -i sc_trans.conf
+ sed -e "s|^PlaylistFile=.*|PlaylistFile=/opt/shoutcast/playlists/example.lst|" -i sc_trans.conf
+ insinto /etc/shoutcast
+ doins sc_trans.conf
+
+ # create a directory for playlists to be put
+ mkdir ${D}/opt/shoutcast/playlists
+}
+
+pkg_postinst() {
+ einfo "Shoutcast-trans can be started via the init.d script provided."
+ einfo "start it with /etc/init.d/shoutcast_trans"
+ einfo
+ einfo "The configuration file is /etc/shoutcast/sc_trans.conf."
+ einfo "Please have a look at the playlist file setting."
+ einfo "A sample playlist file can be found under /usr/share/doc/$P."
+ einfo "It also contains instructions how to build a playlist."
+ einfo "A directory /opt/shoutcast/playlists has been created for storing playlists."
+}