summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-09-12 10:07:19 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-09-12 10:07:19 +0000
commitbeb1e0df179d0c4eb6f3864c5d76a4573bf66375 (patch)
tree437cbaad51af47578e377bf14972e769aee1bf71 /media-tv/mythfrontend
parent!nomirror (diff)
downloadhistorical-beb1e0df179d0c4eb6f3864c5d76a4573bf66375.tar.gz
historical-beb1e0df179d0c4eb6f3864c5d76a4573bf66375.tar.bz2
historical-beb1e0df179d0c4eb6f3864c5d76a4573bf66375.zip
Closing #63672
Diffstat (limited to 'media-tv/mythfrontend')
-rw-r--r--media-tv/mythfrontend/ChangeLog5
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.16.ebuild16
2 files changed, 18 insertions, 3 deletions
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
index bcea82c56be6..181ae3e6b533 100644
--- a/media-tv/mythfrontend/ChangeLog
+++ b/media-tv/mythfrontend/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/mythfrontend
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.21 2004/09/11 12:33:00 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.22 2004/09/12 10:06:59 aliz Exp $
+
+ 12 Sep 2004; Daniel Ahlberg <aliz@gentoo.org> mythfrontend-0.16.ebuild:
+ Make compilation distcc friendly, closing #63672.
11 Sep 2004; Daniel Ahlberg <aliz@gentoo.org> mythfrontend-0.16.ebuild:
Synced dependencies with mythtv.
diff --git a/media-tv/mythfrontend/mythfrontend-0.16.ebuild b/media-tv/mythfrontend/mythfrontend-0.16.ebuild
index 39a5cd306797..6a8b0b67ade0 100644
--- a/media-tv/mythfrontend/mythfrontend-0.16.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.16.ebuild,v 1.3 2004/09/11 12:33:00 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.16.ebuild,v 1.4 2004/09/12 10:06:59 aliz Exp $
inherit myth
@@ -139,6 +139,13 @@ setup_pro() {
-i 'settings.pro' || die "enable xrandr sed failed"
}
+src_unpack() {
+ # Fix bugs 40964 and 42943.
+ filter-flags -fforce-addr -fPIC
+
+ myth_src_unpack
+}
+
src_compile() {
export QMAKESPEC="linux-g++"
@@ -146,7 +153,12 @@ src_compile() {
sed -i -e "s:OPTFLAGS=.*:OPTFLAGS=${CFLAGS}:g" config.mak
qmake -o "Makefile" "mythtv.pro"
- make || die
+ emake -C libs/libavcodec || die
+ emake -C libs/libavformat || die
+ emake -C libs/libmyth || die
+ emake -C libs/libmythtv || die
+ emake -C libs || die
+ emake || die
}
src_install() {