summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-09-13 10:47:16 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-09-13 10:47:16 +0000
commitf3e84bcf7c682461b096febbba831231b9747fe9 (patch)
tree385926f1a61bc700417f84b5d25855867055f45a /media-tv/mythtv
parentfix node updating script (diff)
downloadhistorical-f3e84bcf7c682461b096febbba831231b9747fe9.tar.gz
historical-f3e84bcf7c682461b096febbba831231b9747fe9.tar.bz2
historical-f3e84bcf7c682461b096febbba831231b9747fe9.zip
Added patch from cvs
Diffstat (limited to 'media-tv/mythtv')
-rw-r--r--media-tv/mythtv/ChangeLog5
-rw-r--r--media-tv/mythtv/Manifest5
-rw-r--r--media-tv/mythtv/files/mythtv-0.16-cx88.patch16
-rw-r--r--media-tv/mythtv/mythtv-0.16.ebuild6
4 files changed, 27 insertions, 5 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index dca0cc58615b..3988631961c3 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.35 2004/09/12 10:07:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.36 2004/09/13 10:47:16 aliz Exp $
+
+ 13 Sep 2004; Daniel Ahlberg <aliz@gentoo.org> mythtv-0.16.ebuild:
+ Added patch from CVS to fix cx88 related crashes.
12 Sep 2004; Daniel Ahlberg <aliz@gentoo.org> mythtv-0.16.ebuild:
Make compilation distcc friendly, closing #63672.
diff --git a/media-tv/mythtv/Manifest b/media-tv/mythtv/Manifest
index 1df4aa21e94c..5164e6c5ac41 100644
--- a/media-tv/mythtv/Manifest
+++ b/media-tv/mythtv/Manifest
@@ -1,13 +1,14 @@
MD5 3d9bee3ecb9fb56ee0662360121d9792 mythtv-0.15.1.ebuild 6637
MD5 bb8f641b460d061161d9982b0464b9dc mythtv-0.13-r1.ebuild 4519
-MD5 03993dc01cd09df084c072f6576be4aa mythtv-0.16.ebuild 5616
+MD5 d7a21ed39fb9a126b9f7f2a36199660c mythtv-0.16.ebuild 5660
MD5 ed986a83ce07ad7d884bc14715a48b8b mythtv-0.15.1-r1.ebuild 7656
MD5 069bb2ed03255dd27030c717e89ff508 mythtv-0.14-r1.ebuild 5581
-MD5 c288fcc2034184e1e6ef5578d4b9fab3 ChangeLog 7013
+MD5 028dd500056c0a6cebbc88fb859c4fc0 ChangeLog 7134
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 75594236f281302bcb8f60629e0da65b files/tvformat.fix.0.13.diff 407
MD5 788cdcff1808794391bf5ef2e157b5fb files/digest-mythtv-0.15.1 67
MD5 788cdcff1808794391bf5ef2e157b5fb files/digest-mythtv-0.15.1-r1 67
+MD5 8d46f5508de5d412db9e4a757db00e26 files/mythtv-0.16-cx88.patch 674
MD5 a01439b4ddf480862e31867fc4689698 files/digest-mythtv-0.13-r1 65
MD5 24ab1e90e64fb0be4704e74b633e96b1 files/digest-mythtv-0.14-r1 65
MD5 f61ed76cd0d4dab547459acb1ee99882 files/mythbackend.conf 902
diff --git a/media-tv/mythtv/files/mythtv-0.16-cx88.patch b/media-tv/mythtv/files/mythtv-0.16-cx88.patch
new file mode 100644
index 000000000000..d62377cad2d1
--- /dev/null
+++ b/media-tv/mythtv/files/mythtv-0.16-cx88.patch
@@ -0,0 +1,16 @@
+===================================================================
+RCS file: /var/lib/mythcvs/mythtv/libs/libmythtv/NuppelVideoRecorder.cpp,v
+retrieving revision 1.178
+retrieving revision 1.179
+diff -u -r1.178 -r1.179
+--- mythtv/libs/libmythtv/NuppelVideoRecorder.cpp 2004/08/19 02:02:19 1.178
++++ mythtv/libs/libmythtv/NuppelVideoRecorder.cpp 2004/09/12 19:05:49 1.179
+@@ -1300,7 +1300,7 @@
+
+ uint8_t *y_plane = conversion_buffer;
+ uint8_t *cb_plane = y_plane + w * h;
+- uint8_t *cr_plane = cr_plane + w * h / 4;
++ uint8_t *cr_plane = cb_plane + w * h / 4;
+
+ uint8_t *src = buffers[frame];
+
diff --git a/media-tv/mythtv/mythtv-0.16.ebuild b/media-tv/mythtv/mythtv-0.16.ebuild
index a9de4b2a4537..8e41f9212162 100644
--- a/media-tv/mythtv/mythtv-0.16.ebuild
+++ b/media-tv/mythtv/mythtv-0.16.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.16.ebuild,v 1.5 2004/09/12 10:07:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.16.ebuild,v 1.6 2004/09/13 10:47:16 aliz Exp $
-inherit myth flag-o-matic
+inherit myth flag-o-matic eutils
DESCRIPTION="Homebrew PVR project"
HOMEPAGE="http://www.mythtv.org/"
@@ -141,6 +141,8 @@ src_unpack() {
filter-flags -fforce-addr -fPIC
myth_src_unpack
+
+ epatch ${FILESDIR}/${P}-cx88.patch
}