summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-08-25 15:48:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-08-25 15:48:36 +0000
commit02921fc8a94c99ba9b850fa4edbc397c00371f94 (patch)
treeb22f1de0b6e439064316f320e67abaa3c51c85b1 /media-video/clive
parentRenamed xfce4-mailwatch xfce4-weather xfce4-modemlights. (diff)
downloadhistorical-02921fc8a94c99ba9b850fa4edbc397c00371f94.tar.gz
historical-02921fc8a94c99ba9b850fa4edbc397c00371f94.tar.bz2
historical-02921fc8a94c99ba9b850fa4edbc397c00371f94.zip
version bump
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'media-video/clive')
-rw-r--r--media-video/clive/ChangeLog7
-rw-r--r--media-video/clive/clive-2.2.5.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index f4157fb44dfd..265877547ef4 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.50 2009/08/02 23:00:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.51 2009/08/25 15:48:36 aballier Exp $
+
+*clive-2.2.5 (25 Aug 2009)
+
+ 25 Aug 2009; Alexis Ballier <aballier@gentoo.org> +clive-2.2.5.ebuild:
+ version bump
*clive-2.2.4 (02 Aug 2009)
diff --git a/media-video/clive/clive-2.2.5.ebuild b/media-video/clive/clive-2.2.5.ebuild
new file mode 100644
index 000000000000..d7ce3e815245
--- /dev/null
+++ b/media-video/clive/clive-2.2.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-2.2.5.ebuild,v 1.1 2009/08/25 15:48:36 aballier Exp $
+
+EAPI=2
+
+inherit perl-app
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="http://clive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clipboard pager password"
+
+RDEPEND=">=dev-perl/BerkeleyDB-0.34
+ >=dev-perl/Config-Tiny-2.12
+ >=virtual/perl-Digest-SHA-5.47
+ >=dev-perl/HTML-TokeParser-Simple-2.37
+ >=dev-perl/Class-Singleton-1.4
+ >=dev-perl/WWW-Curl-4.05
+ >=dev-perl/XML-Simple-2.18
+ >=dev-perl/Getopt-ArgvFile-1.11
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ clipboard? ( >=dev-perl/Clipboard-0.09 )
+ pager? ( >=dev-perl/IO-Pager-0.05 )
+ password? ( >=dev-perl/Expect-1.21 )"
+DEPEND=""
+
+SRC_TEST=do
+mydoc="TODO"
+
+src_test() {
+ if [ -z "${I_WANT_CLIVE_HOSTS_TESTS}" ] ; then
+ elog "If you wish to run the full testsuite of ${PN}"
+ elog "Please set the variable 'I_WANT_CLIVE_HOSTS_TESTS' variable"
+ elog "Note that the tests try to download some videos from various websites"
+ elog "and thus may randomly fail depending on the site's status."
+ export NO_INTERNET=1
+ fi
+ perl-module_src_test
+}