summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-07 09:43:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-07 09:43:06 +0000
commitbb64771f1b5a3a8b06a8d408f61f970d142dac96 (patch)
tree39899cf80de09c4f7c7a9b37730407cbbb2c20a5 /media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.0.ebuild
parentreplace qt4 eclass with qt4-r2 (diff)
downloadhistorical-bb64771f1b5a3a8b06a8d408f61f970d142dac96.tar.gz
historical-bb64771f1b5a3a8b06a8d408f61f970d142dac96.tar.bz2
historical-bb64771f1b5a3a8b06a8d408f61f970d142dac96.zip
Version bump.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.0.ebuild')
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.0.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.0.ebuild
new file mode 100644
index 000000000000..1fc5479cdd81
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.0.ebuild,v 1.1 2010/01/07 09:40:53 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
+HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="jpeg png"
+
+RDEPEND=">=media-video/ffmpeg-0.5
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable png) \
+ $(use_enable jpeg)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+ find "${D}"/usr -name '*.la' -delete
+}