summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Tolboom <ryan@gentoo.org>2001-12-14 11:12:03 +0000
committerRyan Tolboom <ryan@gentoo.org>2001-12-14 11:12:03 +0000
commit5e8f18bdcdb9678eb03bff8a52ee394aaa052592 (patch)
tree56cf763e9f0d0facc3c5040b43f427ad2199e18d /media-video/mgavideo
parentNew revision of CDBakeoven, patch added (diff)
downloadhistorical-5e8f18bdcdb9678eb03bff8a52ee394aaa052592.tar.gz
historical-5e8f18bdcdb9678eb03bff8a52ee394aaa052592.tar.bz2
historical-5e8f18bdcdb9678eb03bff8a52ee394aaa052592.zip
Drivers for the Matrox Marvel and Roadrunner MJPEG capture cards
Diffstat (limited to 'media-video/mgavideo')
-rw-r--r--media-video/mgavideo/files/digest-mgavideo-0.1.0.61
-rw-r--r--media-video/mgavideo/mgavideo-0.1.0.6.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-video/mgavideo/files/digest-mgavideo-0.1.0.6 b/media-video/mgavideo/files/digest-mgavideo-0.1.0.6
new file mode 100644
index 000000000000..ce5cc90c69f1
--- /dev/null
+++ b/media-video/mgavideo/files/digest-mgavideo-0.1.0.6
@@ -0,0 +1 @@
+MD5 b2b21cb4de4084b4c64d109ad217e011 mgavideo-0.1.0-test6.tar.gz 245760
diff --git a/media-video/mgavideo/mgavideo-0.1.0.6.ebuild b/media-video/mgavideo/mgavideo-0.1.0.6.ebuild
new file mode 100644
index 000000000000..a60abc9980a5
--- /dev/null
+++ b/media-video/mgavideo/mgavideo-0.1.0.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ryan Tolboom <ryan@gentoo.org>
+
+A=${PN}-0.1.0-test6.tar.gz
+S=${WORKDIR}/${PN}-0.1.0-test6/driver
+SRC_URI="http://prdownloads.sourceforge.net/marvel/${A}"
+DESCRIPTION="Matrox Marvel G200/G400/Rainbow Runner G-series V4L I and II drivers"
+HOMEPAGE="http://marvel.sourceforge.net"
+
+DEPEND="virtual/glibc
+ virtual/kernel"
+
+RDEPEND="virtual/kernel"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # This allows us to compile the i2c-algo-ks.o module even if the user doesn't have
+ # the i2c-core.o module, incase they want to compile that later. At the end of this
+ # script we warn them if that is the case
+
+ cp Makefile Makefile.orig
+ sed -e '/i2c-algo-ks\.o\:/,+3c\
+i2c-algo-ks.o:\
+ \$(CC) \$(CFLAGS) -c i2c-algo-ks.c' Makefile.orig > Makefile
+}
+
+src_compile() {
+ make mjpeg
+}
+
+src_install() {
+ local install_dir=/lib/modules/${KVERS}/kernel/drivers/mgavideo
+
+ dodir ${install_dir}
+ dodoc README CHANGELOG
+ cp i2c-algo-ks.o ${D}/${install_dir}
+ cp tuner.o ${D}/${install_dir}
+ cp ks0127.o ${D}/${install_dir}
+ cp msp3400.o ${D}/${install_dir}
+ cp maven.o ${D}/${install_dir}
+ cp mga_core.o ${D}/${install_dir}
+ cp mgavideo.o ${D}/${install_dir}
+ cp mgacap.o ${D}/${install_dir}
+ cp zr36060.o ${D}/${install_dir}
+ cp i33.o ${D}/${install_dir}
+ cp mgajpg.o ${D}/${install_dir}
+ cp mgagrab.o ${D}/${install_dir}
+}
+
+pkg_postinst() {
+ depmod -a
+ if [ ! -f /lib/modules/${KVERS}/kernel/drivers/i2c/i2c-core.o ] ; then
+ echo
+ echo '###############################################################'
+ echo '## WARNING: i2c support must be compiled into your kernel ##'
+ echo '## as a module for these drivers to work. ##'
+ echo '###############################################################'
+ echo
+ fi
+}