summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-15 23:20:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-15 23:20:08 +0000
commit3e68132bd5c883125ba5ea18667ae221e886ab16 (patch)
tree70ec74e4f9d3c188270b0c38fa9187f413356c83 /media-video/mkvtoolnix/files
parentInstall menu entry, bug #160229 (diff)
downloadhistorical-3e68132bd5c883125ba5ea18667ae221e886ab16.tar.gz
historical-3e68132bd5c883125ba5ea18667ae221e886ab16.tar.bz2
historical-3e68132bd5c883125ba5ea18667ae221e886ab16.zip
Upstream fix for building qt4 gui without wxwindows
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'media-video/mkvtoolnix/files')
-rw-r--r--media-video/mkvtoolnix/files/mkvtoolnix-2.0.2-qt4.patch74
1 files changed, 64 insertions, 10 deletions
diff --git a/media-video/mkvtoolnix/files/mkvtoolnix-2.0.2-qt4.patch b/media-video/mkvtoolnix/files/mkvtoolnix-2.0.2-qt4.patch
index fcdde62e2ea6..2a12015ce28f 100644
--- a/media-video/mkvtoolnix/files/mkvtoolnix-2.0.2-qt4.patch
+++ b/media-video/mkvtoolnix/files/mkvtoolnix-2.0.2-qt4.patch
@@ -1,14 +1,68 @@
-Index: mkvtoolnix-2.0.2/configure.in
+Index: configure.in
===================================================================
---- mkvtoolnix-2.0.2.orig/configure.in
-+++ mkvtoolnix-2.0.2/configure.in
-@@ -1018,8 +1018,7 @@ AC_ARG_ENABLE([qt],
+--- configure.in (revision 3516)
++++ configure.in (working copy)
+@@ -935,9 +935,13 @@
+ AC_ARG_ENABLE([gui],
+ AC_HELP_STRING([--enable-gui],[compile mkvinfo's GUI and mmg (yes)]))
+
++ AC_ARG_ENABLE([wxwidgets],
++ AC_HELP_STRING([--enable-wxwidgets],[compile the wxWidgets version of the GUIs (yes)]))
++
+ wxw_min_ver=2.6.0
+
+- if test x"$enable_gui" = x"yes" -o x"$enable_gui" = "x"; then
++ if test '(' x"$enable_wxwidgets" = xyes -o x"$enable_wxwidgets" = x ')' -a \
++ '(' x"$enable_gui" = xyes -o x"$enable_gui" = x ')'; then
+ AC_ARG_WITH(wx_config,
+ AC_HELP_STRING([--with-wx-config=prog],
+ [use prog instead of looking for wx-config]),
+@@ -985,7 +989,7 @@
+ AC_MSG_RESULT($wxwversion ok)
+ have_wxwindows=yes
+ USE_WXWIDGETS=yes
+- opt_features_yes="$opt_features_yes\n * GUIs"
++ opt_features_yes="$opt_features_yes\n * GUIs (wxWidgets version)"
+ else
+ AC_MSG_RESULT(no: test program could not be compiled)
+ fi
+@@ -1000,7 +1004,7 @@
+ fi
+
+ if test x"$have_wxwindows" != "xyes" ; then
+- opt_features_no="$opt_features_no\n * GUIs"
++ opt_features_no="$opt_features_no\n * GUIs (wxWidgets version)"
+ fi
+
+ AC_SUBST(WXWIDGETS_CFLAGS)
+@@ -1014,7 +1018,7 @@
+ dnl
+
+ AC_ARG_ENABLE([qt],
+- AC_HELP_STRING([--enable-qt],[compile the Qt version of the GUIs]))
++ AC_HELP_STRING([--enable-qt],[compile the Qt version of the GUIs (no)]))
qt_min_ver=4.0.0
--if test x"$enable_qt" = "xyes" -a \
-- '(' x"$enable_gui" = x"yes" -o x"$enable_gui" = "x" ')'; then
-+if test x"$enable_qt" = "xyes"; then
- dnl Find moc.
- AC_ARG_WITH(moc,
- AC_HELP_STRING([--with-moc=prog],[use prog instead of looking for moc]),
+@@ -1158,7 +1162,7 @@
+ AC_DEFINE(HAVE_QT, 1, [Define if Qt is present])
+ have_qt=yes
+ USE_QT=yes
+- opt_features_yes="$opt_features_yes (Qt version)"
++ opt_features_yes="$opt_features_yes\n * GUIs (Qt version)"
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no: test program could not be compiled)
+@@ -1166,6 +1170,11 @@
+ fi
+ fi
+
++if test x"$have_qt" != "xyes" ; then
++ opt_features_no="$opt_features_no\n * GUIs (Qt version)"
++fi
++
++
+ AC_SUBST(MOC)
+ AC_SUBST(UIC)
+ AC_SUBST(QT_CFLAGS)
+