summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-06-30 16:45:23 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-06-30 16:45:23 +0000
commitaa308ae46fa4bb6679214f9d66db25d20431524b (patch)
treeb72670a57a83b59f4f0784938054106cc9ad0d38 /media-video/mplayer/mplayer-9999.ebuild
parentfix automagic dependency against svgalib, add --disable-svgalib --disable-svg... (diff)
downloadhistorical-aa308ae46fa4bb6679214f9d66db25d20431524b.tar.gz
historical-aa308ae46fa4bb6679214f9d66db25d20431524b.tar.bz2
historical-aa308ae46fa4bb6679214f9d66db25d20431524b.zip
Drop svga useflag.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'media-video/mplayer/mplayer-9999.ebuild')
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild21
1 files changed, 4 insertions, 17 deletions
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index 5f13273454c4..5259a2e17ac7 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.69 2010/06/30 16:41:24 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.70 2010/06/30 16:45:23 scarabeus Exp $
EAPI="2"
@@ -17,7 +17,7 @@ doc +dts +dv dvb +dvd +dvdnav dxr3 +enca +encode esd +faac +faad fbcon ftp
gif ggi -gmplayer +iconv ipv6 jack joystick jpeg jpeg2k kernel_linux ladspa
libcaca lirc +live lzo mad md5sum +mmx mmxext mng +mp3 nas +network nut openal
amr +opengl +osdmenu oss png pnm pulseaudio pvr +quicktime radio +rar +real +rtc
-samba +shm +schroedinger sdl +speex sse sse2 ssse3 svga tga +theora +tremor
+samba +shm +schroedinger sdl +speex sse sse2 ssse3 tga +theora +tremor
+truetype +toolame +twolame +unicode v4l v4l2 vdpau vidix +vorbis vpx
win32codecs +X +x264 xanim xinerama +xscreensaver +xv +xvid xvmc zoran"
[[ ${PV} == *9999* ]] && IUSE+=" external-ffmpeg"
@@ -42,8 +42,7 @@ else
fi
SRC_URI="${RELEASE_URI}
!truetype? ( ${FONT_URI} )
- gmplayer? ( mirror://mplayer/skins/Blue-${BLUV}.tar.bz2 )
- svga? ( mirror://gentoo/svgalib_helper-${SVGV}-mplayer.tar.gz )"
+ gmplayer? ( mirror://mplayer/skins/Blue-${BLUV}.tar.bz2 )"
DESCRIPTION="Media Player for Linux"
HOMEPAGE="http://www.mplayerhq.hu/"
@@ -143,7 +142,6 @@ RDEPEND+="
schroedinger? ( media-libs/schroedinger )
sdl? ( media-libs/libsdl )
speex? ( media-libs/speex )
- svga? ( media-libs/svgalib )
theora? ( media-libs/libtheora[encode?] )
truetype? ( ${FONT_RDEPS} )
vorbis? ( media-libs/libvorbis )
@@ -248,7 +246,6 @@ src_unpack() {
fi
use gmplayer && unpack "Blue-${BLUV}.tar.bz2"
- use svga && unpack "svgalib_helper-${SVGV}-mplayer.tar.gz"
}
src_prepare() {
@@ -261,16 +258,6 @@ src_prepare() {
sed -i -e "s/UNKNOWN/${MPLAYER_REVISION}/" "${S}/version.sh" || die
fi
- if use svga; then
- echo
- einfo "Enabling vidix non-root mode."
- einfo "(You need a proper svgalib_helper.o module for your kernel"
- einfo "to actually use this)"
- echo
-
- mv "${WORKDIR}/svgalib_helper" "${S}/libdha"
- fi
-
base_src_prepare
}
@@ -290,6 +277,7 @@ src_configure() {
#Optional features#
###################
myconf+="
+ --disable-svga --enable-svgalib_helper
--disable-arts
--disable-kai
$(use_enable network)
@@ -306,7 +294,6 @@ src_configure() {
use nut || myconf+=" --disable-libnut"
use rar || myconf+=" --disable-unrarexec"
use samba || myconf+=" --disable-smb"
- use svga || myconf+=" --disable-svga --enable-svgalib_helper"
if ! use lirc; then
myconf+="
--disable-lirc