summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-02-06 18:12:33 +0000
committerSteve Dibb <beandog@gentoo.org>2007-02-06 18:12:33 +0000
commitc9171bf6e937579de72d2bd52420e50db2249297 (patch)
treec3cc4cb1a34301561e3736af290e3f6e92e1d29b /media-video/ogmrip/ogmrip-0.10.2.ebuild
parentversion bump (diff)
downloadhistorical-c9171bf6e937579de72d2bd52420e50db2249297.tar.gz
historical-c9171bf6e937579de72d2bd52420e50db2249297.tar.bz2
historical-c9171bf6e937579de72d2bd52420e50db2249297.zip
Version bump, bug 165151
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'media-video/ogmrip/ogmrip-0.10.2.ebuild')
-rw-r--r--media-video/ogmrip/ogmrip-0.10.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-video/ogmrip/ogmrip-0.10.2.ebuild b/media-video/ogmrip/ogmrip-0.10.2.ebuild
new file mode 100644
index 000000000000..5eb565097ad4
--- /dev/null
+++ b/media-video/ogmrip/ogmrip-0.10.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ogmrip/ogmrip-0.10.2.ebuild,v 1.1 2007/02/06 18:12:33 beandog Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Graphical frontend and libraries for ripping DVDs and encoding to AVI/OGM/MKV/MP4"
+HOMEPAGE="http://ogmrip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="aac debug doc gtk hal matroska spell srt theora"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-libs/libxml2-2
+ >=media-libs/libdvdread-0.9.4
+ >=media-sound/lame-3.96
+ >=media-sound/ogmtools-1.4
+ >=media-sound/vorbis-tools-1.0
+ aac? ( >=media-libs/faac-1.24 )
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=gnome-base/gconf-2.6
+ >=gnome-base/libglade-2.5 )
+ hal? ( >=sys-apps/hal-0.4.2 )
+ matroska? ( >=media-video/mkvtoolnix-0.9 )
+ spell? ( >=app-text/enchant-1.1 )
+ srt? ( >=app-text/gocr-0.39 )
+ theora? ( >=media-libs/libtheora-1.0_alpha6 )"
+
+DEPEND="${RDEPEND}
+ >=media-video/mplayer-1.0_pre4
+ >=dev-util/intltool-0.29
+ >=dev-util/pkgconfig-0.12.0"
+
+G2CONF="${G2CONF}
+ $(use_enable aac aac-support)
+ $(use_enable debug maintainer-mode)
+ $(use_enable gtk gtk-support)
+ $(use_enable hal hal-support)
+ $(use_enable matroska matroska-support)
+ $(use_enable spell enchant-support)
+ $(use_enable srt srt-support)
+ $(use_enable theora theora-support)"
+
+DOCS="AUTHORS ChangeLog README NEWS TODO"
+
+pkg_setup() {
+ if ! built_with_use -a media-video/mplayer dvd encode xvid; then
+ eerror "Please, check that your USE flags contain 'dvd', 'encode' and"
+ eerror "'xvid' and emerge mplayer again."
+ die "MPlayer is not built with dvd, encoding or xvid support."
+ fi
+}