summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2010-07-30 11:11:10 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2010-07-30 11:11:10 +0000
commitba0c14547b32105b8467a2811e3e4b63139a1d34 (patch)
tree80a93b1116e95fa0e8b99c1dd37444c4f51ff391 /media-video/tsmuxer/tsmuxer-1.10.6-r1.ebuild
parentSecurity version bump, bug #330205. Remove the older 1.7.x. (diff)
downloadhistorical-ba0c14547b32105b8467a2811e3e4b63139a1d34.tar.gz
historical-ba0c14547b32105b8467a2811e3e4b63139a1d34.tar.bz2
historical-ba0c14547b32105b8467a2811e3e4b63139a1d34.zip
reworked ebuild, added missing dependencies, decompress executables with upx. thanks to beandog@gentoo.org
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'media-video/tsmuxer/tsmuxer-1.10.6-r1.ebuild')
-rw-r--r--media-video/tsmuxer/tsmuxer-1.10.6-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-video/tsmuxer/tsmuxer-1.10.6-r1.ebuild b/media-video/tsmuxer/tsmuxer-1.10.6-r1.ebuild
new file mode 100644
index 000000000000..94be0b6b7b90
--- /dev/null
+++ b/media-video/tsmuxer/tsmuxer-1.10.6-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/tsmuxer/tsmuxer-1.10.6-r1.ebuild,v 1.1 2010/07/30 11:11:10 sbriesen Exp $
+
+EAPI="2"
+
+inherit base qt4-r2
+
+DESCRIPTION="Utility to create and demux TS and M2TS files"
+HOMEPAGE="http://www.smlabs.net/tsmuxer_en.html"
+SRC_URI="http://www.smlabs.net/tsMuxer/tsMuxeR_shared_${PV}.tar.gz"
+LICENSE="SmartLabs"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4 linguas_ru"
+
+QA_DT_HASH="opt/${PN}/bin/tsMuxeR opt/${PN}/bin/tsMuxerGUI"
+
+DEPEND="|| (
+ >=app-arch/upx-ucl-3.01
+ >=app-arch/upx-3.01
+)"
+
+RDEPEND="
+ x86? (
+ media-libs/freetype:2
+ qt4? ( x11-libs/qt-gui:4 )
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-xlibs
+ qt4? ( >=app-emulation/emul-linux-x86-qtlibs-20081109 )
+ )"
+
+# cli is linked to freetype, when it will be fixed,
+# we will remove app-emulation/emul-linux-x86-xlibs dep.
+
+S="${WORKDIR}"
+
+src_prepare() {
+ upx -d tsMuxeR tsMuxerGUI || die
+}
+
+src_install() {
+ dodir /opt/bin
+ exeinto /opt/${PN}/bin
+
+ doexe tsMuxeR
+ dosym ../${PN}/bin/tsMuxeR /opt/bin
+
+ if use qt4; then
+ doexe tsMuxerGUI
+ dosym ../${PN}/bin/tsMuxerGUI /opt/bin
+ newicon "${FILESDIR}/icon.png" "${PN}.png"
+ make_desktop_entry tsMuxerGUI "tsMuxeR GUI" "${PN}" "Qt;AudioVideo;Video"
+ fi
+
+ use linguas_ru && dodoc readme.rus.txt
+}