summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-15 19:13:56 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-15 19:13:56 +0000
commit47479ca6880ed94841c13ae3793490b94c321d7c (patch)
treea7a92d1e4ddbf6182f8dbc99c76f956d80ebd433 /media-video
parent*** empty log message *** (diff)
downloadhistorical-47479ca6880ed94841c13ae3793490b94c321d7c.tar.gz
historical-47479ca6880ed94841c13ae3793490b94c321d7c.tar.bz2
historical-47479ca6880ed94841c13ae3793490b94c321d7c.zip
*** empty log message ***
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpeg-movie/files/digest1
-rw-r--r--media-video/mpeg-movie/mpeg-movie-1.6.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/media-video/mpeg-movie/files/digest b/media-video/mpeg-movie/files/digest
new file mode 100644
index 000000000000..f2af00de0c19
--- /dev/null
+++ b/media-video/mpeg-movie/files/digest
@@ -0,0 +1 @@
+MD5 6e87f6b84143f925be123388d72ae9c5 mpeg_movie-1.6.0.tar.gz
diff --git a/media-video/mpeg-movie/mpeg-movie-1.6.0.ebuild b/media-video/mpeg-movie/mpeg-movie-1.6.0.ebuild
new file mode 100644
index 000000000000..c988bd9feb10
--- /dev/null
+++ b/media-video/mpeg-movie/mpeg-movie-1.6.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg-movie/mpeg-movie-1.6.0.ebuild,v 1.1 2000/08/15 19:13:56 achim Exp $
+
+P=mpeg-movie-1.6.0
+A=mpeg_movie-1.6.0.tar.gz
+S=${WORKDIR}/mpeg_movie
+CATEGORY="media-video"
+DESCRIPTION="Tools for MPEG-I movies"
+SRC_URI="http://heroine.linuxave.net/${A}"
+HOMEPAGE="http://heroine.linuxave.net/toys.html"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ for i in video_in video_out
+ do
+ cd ${S}/${i}
+ cp Makefile Makefile.orig
+ sed -e "s:gnu/types\.h:bits/types\.h:" \
+ -e "s:stdio_lim\.h:bits/stdio_lim\.h:" \
+ -e "s:bytesex\.h::" \
+ -e "s:selectbits\.h::" \
+ -e "s:huge_val\.h:bits/huge_val\.h:" \
+ -e "s:mathcalls\.h:bits/mathcalls\.h:" \
+ -e "s:posix1_lim\.h:bits/posix1_lim\.h:" \
+ -e "s:posix2_lim\.h:bits/posix2_lim\.h:" \
+ -e "s:posix_opt\.h:bits/posix_opt\.h:" \
+ -e "s:local_lim\.h:bits/local_lim\.h:" \
+ -e "s:socketbits\.h::" \
+ -e "s:sockaddrcom\.h::" \
+ -e "s:errnos\.h::" \
+ -e "s:statbuf\.h::" \
+ -e "s:ipc_buf\.h::" \
+ -e "s:shm_buf\.h::" \
+ -e "s:timebits\.h::" \
+ -e "s:confname\.h:bits/confname\.h:" \
+ -e "s:sigset\.h:bits/sigset\.h:" \
+ -e "s:signum\.h:bits/signum\.h:" \
+ -e "s:sigaction\.h:bits/sigaction\.h:" \
+ -e "s:asm/sigcontext\.h:bits/sigcontext\.h:" \
+ -e "s:include/sigcontext\.h:include/bits/sigcontext\.h:" \
+ Makefile.orig > Makefile
+
+ done
+ cd ${S}/audio_out
+ cp GNUmake GNUmake.orig
+ sed -e "s:SDL_DIR += /usr/local:SDL_DIR += /usr:" GNUmake.orig > GNUmake
+}
+src_compile() {
+
+ cd ${S}
+ make
+
+}
+
+src_install () {
+
+ cd ${S}
+ into /usr
+ dobin audio_in/encode
+ dobin audio_out/plaympeg
+ dobin mplex_in/mplex
+ dobin mplex_out/dmplex
+ dobin video_in/mpeg_encode
+ dobin video_out/mpeg_play
+
+ dodoc docs/*.txt
+ docinto html
+ dodoc docs/index.html
+ docinto html/quicktime
+ dodoc quicktime4linux/src/docs/*.html
+}
+
+
+