summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2002-12-17 19:05:31 +0000
committerBart Lauwers <blauwers@gentoo.org>2002-12-17 19:05:31 +0000
commit9e2a9089dc9ca939987e5902f133867779b0c4bf (patch)
treef4401a4e0ce97431c9a22ba07220de4b341b3f70 /media-video
parentfixed header (diff)
downloadhistorical-9e2a9089dc9ca939987e5902f133867779b0c4bf.tar.gz
historical-9e2a9089dc9ca939987e5902f133867779b0c4bf.tar.bz2
historical-9e2a9089dc9ca939987e5902f133867779b0c4bf.zip
Dependency fix per Bug #12067
Diffstat (limited to 'media-video')
-rw-r--r--media-video/nvtv/ChangeLog11
-rw-r--r--media-video/nvtv/files/digest-nvtv-0.4.2-r11
-rw-r--r--media-video/nvtv/nvtv-0.4.2-r1.ebuild50
3 files changed, 56 insertions, 6 deletions
diff --git a/media-video/nvtv/ChangeLog b/media-video/nvtv/ChangeLog
index 2df7adf8e2c2..29d4a59f3291 100644
--- a/media-video/nvtv/ChangeLog
+++ b/media-video/nvtv/ChangeLog
@@ -1,25 +1,24 @@
# ChangeLog for media-video/nvtv
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/nvtv/ChangeLog,v 1.3 2002/12/08 23:35:17 blauwers Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/nvtv/ChangeLog,v 1.4 2002/12/17 19:05:31 blauwers Exp $
-*nvtv-0.2.0-0 (09 Dec 2002)
+*nvtv-4.2.0-0 (09 Dec 2002)
- 9 Dec 2002; B.Lauwers <blauwers@gentoo.org> nvtv-0.4.2.ebuild :
+ 17 Dec 2002; B.Lauwers <blauwers@gentoo.org> nvtv-0.4.2r1.ebuild :
+ Depency bug fixed per Bug#12067
+ 9 Dec 2002; B.Lauwers <blauwers@gentoo.org> nvtv-0.4.2.ebuild :
New version from prior ebuild plus various cleanups
*nvtv-0.4.0-0 (04 Jun 2002)
4 Jun 2002; B.Lauwers <blauwers@gentoo.org> nvtv-0.4.0.ebuild :
-
New version from prior ebuild plus various cleanups
*nvtv-0.3.0-0 (03 May 2002)
3 May 2002; Arcady Genkin <agenkin@thpoon.com> nvtv-0.3.0.ebuild :
-
Cleaned up a few things.
3 May 2002; B.Lauwers <blauwers@gentoo.com> ChangeLog, nvtv-0.3.0.ebuild :
-
Intial ebuild for nvtv from http://sourceforge.net/projects/nv-tv-out
diff --git a/media-video/nvtv/files/digest-nvtv-0.4.2-r1 b/media-video/nvtv/files/digest-nvtv-0.4.2-r1
new file mode 100644
index 000000000000..267e2a42239b
--- /dev/null
+++ b/media-video/nvtv/files/digest-nvtv-0.4.2-r1
@@ -0,0 +1 @@
+MD5 46b1f6b158c794440b6d34595cd3542b nvtv-0.4.2.tar.gz 364162
diff --git a/media-video/nvtv/nvtv-0.4.2-r1.ebuild b/media-video/nvtv/nvtv-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..8fb7efb9b19b
--- /dev/null
+++ b/media-video/nvtv/nvtv-0.4.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/nvtv/nvtv-0.4.2-r1.ebuild,v 1.1 2002/12/17 19:05:31 blauwers Exp $
+
+DESCRIPTION="TV-Out for NVidia cards"
+HOMEPAGE="http://sourceforge.net/projects/nv-tv-out/"
+SRC_URI="mirror://sourceforge/nv-tv-out/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="X gtk gtk2"
+
+DEPEND="sys-apps/pciutils
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )
+ X? ( >=x11-base/xfree-4.0 )"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ local myconf
+
+ if use gtk2; then
+ myconf="${myconf} --with-gtk=gtk2"
+ elif use gtk; then
+ myconf="${myconf} --with-gtk=gtk1"
+ else
+ myconf="${myconf} --without-gtk";
+ fi
+
+ use X && myconf="${myconf} --with-x" || myconf="${myconf} --without-x"
+
+ econf ${myconf}
+
+ # The CFLAGS don't seem to make it into the Makefile.
+ cd src
+ emake CXFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin src/nvtv
+ dosbin src/nvtvd
+
+ dodoc ANNOUNCE BUGS FAQ INSTALL README \
+ doc/USAGE doc/chips.txt doc/overview.txt \
+ doc/timing.txt xine/tvxine
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/nvtv.start nvtv
+}