summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-03-08 11:30:16 +0000
committerPeter Volkov <pva@gentoo.org>2009-03-08 11:30:16 +0000
commit796d0abaea76a4cd37da5ff862c6318fd2554b35 (patch)
tree18547074d0e4f81424c529939578d795db979203 /net-analyzer/cacti-spine
parentVersion bump, bug #261463, thank Thomas Beinicke for report. (diff)
downloadhistorical-796d0abaea76a4cd37da5ff862c6318fd2554b35.tar.gz
historical-796d0abaea76a4cd37da5ff862c6318fd2554b35.tar.bz2
historical-796d0abaea76a4cd37da5ff862c6318fd2554b35.zip
Version bump.
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/ChangeLog9
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-0.8.7c.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/net-analyzer/cacti-spine/ChangeLog b/net-analyzer/cacti-spine/ChangeLog
index 25ecdfd534b4..3bbcaf6c87ad 100644
--- a/net-analyzer/cacti-spine/ChangeLog
+++ b/net-analyzer/cacti-spine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti-spine
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-spine/ChangeLog,v 1.10 2008/08/20 05:27:03 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-spine/ChangeLog,v 1.11 2009/03/08 11:30:16 pva Exp $
+
+*cacti-spine-0.8.7c (08 Mar 2009)
+
+ 08 Mar 2009; Peter Volkov <pva@gentoo.org> +cacti-spine-0.8.7c.ebuild:
+ Version bump.
20 Aug 2008; Peter Volkov <pva@gentoo.org> Manifest:
Fix digest, bug #235206, thank GES for report.
diff --git a/net-analyzer/cacti-spine/cacti-spine-0.8.7c.ebuild b/net-analyzer/cacti-spine/cacti-spine-0.8.7c.ebuild
new file mode 100644
index 000000000000..7a0aaa8e34f8
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-0.8.7c.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-spine/cacti-spine-0.8.7c.ebuild,v 1.1 2009/03/08 11:30:16 pva Exp $
+
+inherit autotools
+
+if [[ ${PV} =~ (_p)([0-9]+) ]] ; then
+ inherit subversion
+ SRC_URI=""
+ MTSLPT_REV=${BASH_REMATCH[2]}
+ ESVN_REPO_URI="svn://svn.cacti.net/var/svnroot/cacti/spine/branches/0.8.7/@${MTSLPT_REV}"
+else
+ MY_PV=${PV/_p/-}
+ SRC_URI="http://www.cacti.net/downloads/spine/${PN}-${MY_PV}.tar.gz"
+fi
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-analyzer/net-snmp
+ dev-libs/openssl
+ virtual/mysql"
+RDEPEND="${DEPEND}
+ >net-analyzer/cacti-0.8.7"
+
+src_unpack() {
+ if [[ "${SRC_URI}" == "" ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+ cd "${S}"
+ sed -i -e 's/^bin_PROGRAMS/sbin_PROGRAMS/' Makefile.am
+ rm configure # configure is not executable, autoconf recreates it...
+ eautoreconf
+}
+
+src_install() {
+ dosbin spine || die
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf.dist spine.conf || die
+ dodoc ChangeLog README || die
+}
+
+pkg_postinst() {
+ ewarn "NOTE: If you upgraded from cactid, do not forgive to setup spine"
+ ewarn "instead of cactid through web interface."
+ ewarn
+ elog "Please see the cacti's site for installation instructions:"
+ elog
+ elog "http://cacti.net/spine_install.php"
+ echo
+ ewarn "/etc/spine.conf should be readable by webserver, thus after you"
+ ewarn "decide on webserver do not forget to run the following command:"
+ ewarn
+ ewarn " # chown root:wwwgroup /etc/spine.conf"
+ echo
+}