summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-12-12 08:30:17 +0000
committerPeter Volkov <pva@gentoo.org>2011-12-12 08:30:17 +0000
commit999502db72e2e4353dc0de53ee284f80b1af6cb3 (patch)
tree0041cc1d445b556fb02435eb831ef1de9ddf22f3 /net-analyzer/cacti-spine
parentVersion bump. Plugin architecture is now includded, bug #346741 wrt Jens Ott ... (diff)
downloadhistorical-999502db72e2e4353dc0de53ee284f80b1af6cb3.tar.gz
historical-999502db72e2e4353dc0de53ee284f80b1af6cb3.tar.bz2
historical-999502db72e2e4353dc0de53ee284f80b1af6cb3.zip
Version bump.
Package-Manager: portage-2.1.10.39/cvs/Linux x86_64
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/ChangeLog7
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-0.8.7i.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-analyzer/cacti-spine/ChangeLog b/net-analyzer/cacti-spine/ChangeLog
index 9dbf265af6de..d0820949bc58 100644
--- a/net-analyzer/cacti-spine/ChangeLog
+++ b/net-analyzer/cacti-spine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti-spine
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-spine/ChangeLog,v 1.29 2011/11/13 14:51:45 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-spine/ChangeLog,v 1.30 2011/12/12 08:30:17 pva Exp $
+
+*cacti-spine-0.8.7i (12 Dec 2011)
+
+ 12 Dec 2011; Peter Volkov <pva@gentoo.org> +cacti-spine-0.8.7i.ebuild:
+ Version bump.
13 Nov 2011; Markus Meier <maekke@gentoo.org> cacti-spine-0.8.7h.ebuild:
x86 stable, bug #387661
diff --git a/net-analyzer/cacti-spine/cacti-spine-0.8.7i.ebuild b/net-analyzer/cacti-spine/cacti-spine-0.8.7i.ebuild
new file mode 100644
index 000000000000..61a4395317ea
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-0.8.7i.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-spine/cacti-spine-0.8.7i.ebuild,v 1.1 2011/12/12 08:30:17 pva Exp $
+
+EAPI="4"
+inherit autotools
+
+UPSTREAM_PATCHES=""
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-analyzer/net-snmp
+ dev-libs/openssl
+ virtual/mysql"
+RDEPEND="${DEPEND}
+ >net-analyzer/cacti-0.8.7"
+
+if [[ -n ${UPSTREAM_PATCHES} ]]; then
+ for i in ${UPSTREAM_PATCHES}; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/spine/patches/${PV}/${i}.patch"
+ done
+fi
+
+src_prepare() {
+ if [[ -n ${UPSTREAM_PATCHES} ]]; then
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -N" epatch "${DISTDIR}"/${i}.patch
+ done
+ fi
+
+ sed -i -e 's/^bin_PROGRAMS/sbin_PROGRAMS/' Makefile.am
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine || die
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,} || die
+ dodoc ChangeLog README || die
+}
+
+pkg_postinst() {
+ elog "Please see the cacti's site for installation instructions:"
+ elog
+ elog "http://cacti.net/spine_install.php"
+ echo
+ ewarn "/etc/spine.conf should be readable by webserver, thus after you"
+ ewarn "decide on webserver do not forget to run the following command:"
+ ewarn
+ ewarn " # chown root:<wwwgroup> /etc/spine.conf"
+ echo
+}