summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-05 16:22:05 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-05 16:22:05 +0000
commit80cc5a3f5b268b3e7665b21716984e8a042e54f9 (patch)
treefedd4de3febb7ea9d316bdbee8207022e2791915 /net-analyzer/gr-fosphor
parentMarked stable on AMD64 based on arch testing by Elijah "Armageddon" El Lazkan... (diff)
downloadhistorical-80cc5a3f5b268b3e7665b21716984e8a042e54f9.tar.gz
historical-80cc5a3f5b268b3e7665b21716984e8a042e54f9.tar.bz2
historical-80cc5a3f5b268b3e7665b21716984e8a042e54f9.zip
Initial commit.
Package-Manager: portage-2.2.7/cvs/Linux x86_64
Diffstat (limited to 'net-analyzer/gr-fosphor')
-rw-r--r--net-analyzer/gr-fosphor/ChangeLog9
-rw-r--r--net-analyzer/gr-fosphor/Manifest3
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild58
-rw-r--r--net-analyzer/gr-fosphor/metadata.xml9
4 files changed, 79 insertions, 0 deletions
diff --git a/net-analyzer/gr-fosphor/ChangeLog b/net-analyzer/gr-fosphor/ChangeLog
new file mode 100644
index 000000000000..4639e8959f1a
--- /dev/null
+++ b/net-analyzer/gr-fosphor/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-analyzer/gr-fosphor
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gr-fosphor/ChangeLog,v 1.1 2013/11/05 16:22:01 chithanh Exp $
+
+*gr-fosphor-9999 (05 Nov 2013)
+
+ 05 Nov 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +gr-fosphor-9999.ebuild, +metadata.xml:
+ Initial commit.
diff --git a/net-analyzer/gr-fosphor/Manifest b/net-analyzer/gr-fosphor/Manifest
new file mode 100644
index 000000000000..44854d296688
--- /dev/null
+++ b/net-analyzer/gr-fosphor/Manifest
@@ -0,0 +1,3 @@
+EBUILD gr-fosphor-9999.ebuild 1291 SHA256 c56e6e5c8264c1c1324b8336eeaec387c78326349be0d68f796d724138e9f76a SHA512 f00f591f13a01257aa56a19fb5e994009869b40e82b873043dd4e1df82671d86fbc17e91104381b2f7574a2aec073abe8025435910f3a90ca3c56358d8bc6c18 WHIRLPOOL 4e102f41cc6c896a1ccfaf2e7b8190e0e9d2b326e9aa3c8171780f62519c8245e4c206688b16239fb061e7cc76882cb295c4e738204a24f78038953fbb9f6bf4
+MISC ChangeLog 382 SHA256 1f89d5415d0a3a9bfeee7c683308dba7cfbe6ad182f2eb2386d2af167b3eea9b SHA512 ce89607e89278f7c369f864a150ef7979e774e5975b69495da66026d3add34cc36b117c77e1a46326507be9a78f2a9db48e6c5547168ee781857a10b9fcf2ef3 WHIRLPOOL 598cc2bae3b52de2939583c33376821ef25d021bfe606985ef73492c896298552e6dd2cdeb15ee47bb9c0089f763177f6e268cf01fc2911c01f5180600626858
+MISC metadata.xml 230 SHA256 4948ba6944b379c066b5f98be30cb51fae51573c3a408a35d76dc3fbc12d056f SHA512 b30556c1ef6f0d33afd8201c0bea90694d5a48dd91579bbed6924d356ceb4db0c0744571c0f4aade499cc1073ae3746e842fbd76308a3471b60304a0d2417bc7 WHIRLPOOL 24f13218a8ee1cacbaa586579cad18f8d3f0618817f8dbf67575501e1b935706c09c553338318edd7d63789fea38d549cd066b00dbe56b118909cc35fd8c4173
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
new file mode 100644
index 000000000000..c30874da2627
--- /dev/null
+++ b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild,v 1.1 2013/11/05 16:22:01 chithanh Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="gnuradio fosphor block (GPU spectrum display)"
+HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="glfw qt4 wxwidgets"
+
+RDEPEND="qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ >=net-wireless/gnuradio-3.7_rc:0=[qt4?,wxwidgets?]
+ glfw? ( >=media-libs/glfw-3 )
+ virtual/opencl
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ dev-lang/swig:0
+ dev-util/cppunit
+"
+
+src_prepare() {
+ python_fix_shebang python/wx_sink_c.py
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ # tries to run OpenCL test program, but failing doesn't hurt
+ addpredict /dev/dri
+
+ local mycmakeargs="
+ $(cmake-utils_use_enable glfw GLFW)
+ $(cmake-utils_use_enable qt4 QT)
+ $(cmake-utils_use_enable wxwidgets WX)
+ -DENABLE_PYTHON=ON
+ "
+ cmake-utils_src_configure
+}
diff --git a/net-analyzer/gr-fosphor/metadata.xml b/net-analyzer/gr-fosphor/metadata.xml
new file mode 100644
index 000000000000..192bccb822ca
--- /dev/null
+++ b/net-analyzer/gr-fosphor/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>radio</herd>
+ <use>
+ <flag name='glfw'>enable GLFW based interface</flag>
+ </use>
+</pkgmetadata>
+