summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLina Pezzella <j4rg0n@gentoo.org>2005-02-10 01:45:48 +0000
committerLina Pezzella <j4rg0n@gentoo.org>2005-02-10 01:45:48 +0000
commitfd387708ed34750d485cc2c3304b522bd9200c05 (patch)
tree1547b9d95de30672b39ff3117799c8b780ff6423 /net-analyzer/netselect/netselect-0.3-r1.ebuild
parentCheck user only when changing implementation. Fix libglx bug #79552. (diff)
downloadhistorical-fd387708ed34750d485cc2c3304b522bd9200c05.tar.gz
historical-fd387708ed34750d485cc2c3304b522bd9200c05.tar.bz2
historical-fd387708ed34750d485cc2c3304b522bd9200c05.zip
Unstable ppc-macos
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'net-analyzer/netselect/netselect-0.3-r1.ebuild')
-rw-r--r--net-analyzer/netselect/netselect-0.3-r1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/net-analyzer/netselect/netselect-0.3-r1.ebuild b/net-analyzer/netselect/netselect-0.3-r1.ebuild
index a1d02c1ad329..7f4d8849787c 100644
--- a/net-analyzer/netselect/netselect-0.3-r1.ebuild
+++ b/net-analyzer/netselect/netselect-0.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r1.ebuild,v 1.8 2004/11/22 16:26:37 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r1.ebuild,v 1.9 2005/02/10 01:45:48 j4rg0n Exp $
inherit flag-o-matic
@@ -10,13 +10,13 @@ SRC_URI="http://www.worldvisions.ca/~apenwarr/netselect/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc ~mips alpha ~arm hppa amd64 ~ia64 ~ppc64 ~s390"
+KEYWORDS="x86 ~ppc sparc ~mips alpha ~arm hppa amd64 ~ia64 ~ppc64 ~s390 ~ppc-macos"
IUSE=""
S="${WORKDIR}/${PN}"
src_compile() {
- append-ldflags "-Wl,-z,now"
+ use ppc-macos || append-ldflags "-Wl,-z,now"
sed -i \
-e "s:PREFIX =.*:PREFIX = ${D}usr:" \
@@ -26,6 +26,9 @@ src_compile() {
-e '34d' \
Makefile \
|| die "sed Makefile failed"
+ if use ppc-macos; then
+ sed -i -e "s:<endian.h>:<machine/endian.h>:" netselect.c || die "sed Makefile failed"
+ fi
emake || die "emake failed"
}